Laptop - only 3Mb?



  • Hi,
    I've just switched to pfsense from ipcop [old BSD fan…] and was expecting some good performance but dissapointed so far.

    Before:
    I had by Broadband going into an Speedtouch ADSL router device giving me approx 16Mb/s down / 1 Mb/s up

    After:
    I got a 400Mhz P2 laptop and bought 2x 3com 100Mb PCMCIA NICS and installed pfsense then plugged in a small cheap 5 port 100mb switch
    [powered by USB….]
    Now I get approx 3-4 Mb/s down and 1Mb/s up

    Looks like the box can't handle anymore throughput!!! Very disappointed.

    Please can anyone advise how to check what the bottleneck is?

    The CPU load is not at 100% when downloading and ram is 128Mb and not fully used.

    _just booting from the CD and managed to get 5Mb download which is better but still very poor.

    Does this sound right? Any other laptop experiences out there?_



  • If the CPU isn't maxed, it shouldn't be a hardware bottleneck.

    Check the Status -> Interfaces page for errors.



  • OK.
    WAN:
    In/out packets  1024883/661836 (1.19 GB/73.64 MB)
    In/out errors 1813/2
    Collisions 0

    LAN:
    n/out packets  927104/1267146 (153.85 MB/1.25 GB)
    In/out errors 0/5
    Collisions 0

    How can I check if the cards are set at 100Mb and Full duplex? I can't even see how it is set so far…..
    Here is out put from ifconfig -a:

    ep0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    inet6 fe80::204:75ff:fe7e:dee0%ep0 prefixlen 64 scopeid 0x5
    inet <removed>netmask 0xfffffc00 broadcast <removed>ether 00:04:75:7e:de:e0
    ep1: flags=8943 <up,broadcast,running,promisc,simplex,multicast>mtu 1500
    inet 192.168.1.50 netmask 0xffffff00 broadcast 192.168.1.255
    inet6 fe80::201:3ff:fec7:1429%ep1 prefixlen 64 scopeid 0x6
    ether 00:01:03:c7:14:29

    I ran iperf between a PC on the same switch as the lan port and got ~7.5Mb/s TCP and terrible UDP but maybe I haven't read how to use it yet.</up,broadcast,running,promisc,simplex,multicast></removed></removed></up,broadcast,running,simplex,multicast>



  • status –> inteface

    could it be that these PCMCIA cards just dont perform too well?



  • Thanks,

    But status-> interface just shows "up" no detail, no media type, duplex setting oranything. I get more details from running ifconfig -a but still no deuplex or speed settings.

    I know the cards might not work very well which is why I want to know how to check their settings under freebsd.

    Could the switch be causing problems with autonegotiation? It is a very tiny switch i got free at a conference and is powered off the usb port of the laptop?



  • I tried the following:

    ifconfig ep0 mediaopt full-duplex

    ifconfig: SIOCGIFMEDIA: Invalid argument

    ifconfig ep0 media 100baseTX

    ifconfig: SIOCGIFMEDIA: Invalid argument

    Is there another way to check /set the speed and duplex?



  • There is a hidden status page you want to look at:
    https://<pfsense-ip>/status.php#Interfaces

    The interface section should show something like:

    fxp0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=8 <vlan_mtu>inet6 fe80::… %fxp0 prefixlen 64 scopeid 0x1
    ether 00:30:...
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active
    xl0: flags=8843 <up,broadcast,running,simplex,multicast>mtu 1500
    options=9 <rxcsum,vlan_mtu>inet 10.0.1.1 netmask 0xffffff00 broadcast 10.0.1.255
    inet6 fe80::... %xl0 prefixlen 64 scopeid 0x2
    ether 00:a0:...
    media: Ethernet autoselect (100baseTX <full-duplex>)
    status: active

    What you see from  Status | Interfaces  is the graphically appealing version of these information.

    If the interfaces do not show the information above this should be a hint to a whacky or unsupported driver...

    The  In/out errors 1813/2  in your post don't look sexy. This could be the switch or the card. Or, unlikely, a cable.</full-duplex></rxcsum,vlan_mtu></up,broadcast,running,simplex,multicast></full-duplex></vlan_mtu></up,broadcast,running,simplex,multicast></pfsense-ip>



  • Thanks for the hint!

    The interfaces section is just showing the output of ifconfig -a which for my cards has no duplex or speed info.

    The cards are 3Com Megahertz 10/100 LAN PC Card labelled Model 3CCFE574BT

    ep0: <3Com Megahertz 574B> at port 0x800-0x81f irq 11 function 0 config 1 on pccard0
    ep0: Ethernet address: 00:04:75:7e:de:e0

    Just in case anyone has one.

    I'll try a different switch at some point then see if I can get them working at all otherwise back to ebay.

    How do i tell if my laptop can use 32 bit [cardbus?] cards?

    There's a Netgear fa511 but i can only fit one of these on the top slot by the look…..



  • Well I have done some iperf tests using my hardware to see why my pfsense install has such low throughput

    8 port 100Mb Switch

    PC [Fujitsu P4 3.2 HT 1.5G RAM, 100Mb NIC] Ubuntu 7.10
    Laptop1 [Acer Aspire 5512, P4 1.7Gz, 1G RAM] Ubuntu 7.10
    Laptop2 [Compaq Evo P3 866Mhz, 256Mb RAM] Fedora (installed about 18months ago and not updated)
    Laptop3 [Compaq Armada 1750, P2 400Mhz, 128Mb RAM] pfsense

    The Acer has a builtin Gb Ethernet  and 1 PCMCIA slot
    The Evo has a builtin 100Mb Ethernet and 2 PCMCIA slots
    The Armada has no builtin ethernet but 2 PCMCIA slots

    NICs:
    Builtin:
    PC : 100Mb lan
    ACER : 10/100/1000Mb [Ubuntu reprts NetXtreme BCM5788 Gigabit Ethernet]
    Compaq : 10/100/1000Mb [fxp0 under pfsense / intel under Fedora]
    PCMCIA:
    Xircom 10/100 CreditCard Ethernet 10/100 - Model CE3B-100 with dongle
    [Multiple] 3COM Megahertz 10/100 - Model 3CCFE574BT with multiple dongles
    Toshiba Advanced PC Card Ethernet (10/100 Upgradeable) TPCENET - (i think dongle is only 10Mb)

    I used iperf with default settings just to indicate what various PCMCIA nics could do:

    The switch has lights which all show 100Mb Full duplex in all tests except the Tosh PCcard

    Acer [Builtin] LAN -> PC = 75/95 Mb/s :[This proves the switch & network & PC is ok]
    Acer [3Com] -> PC = ~7.5 Mb/s :
    Acer [Xircom] -> PC : Something went wrong here. Ubuntu doesn't like the card and autonegotiated only 10Mb HD. iperf got about 50Kb/s!! I manually can set it to 100Mb FD using mii-tools but still gets roughly the same throughput.
    Acer [Toshiba card] -> PC: This card only seems to work at 10Mb Half Duplex. Mii-tools can't change this - i think i only have the 10Mb dongle. I got about 7Mb/s

    Evo [Builtin] -> PC: 95Mb/s: [proves switch, network & PC are OK, ALSO shows that EVO can handle ful speed]
    Evo [3 COM] -> PC: mii-tools works and checking shows 100Mb FD. Througput is about 15MB/s?!?
    Evo [Xircom] -> PC: got about 12Mb/s ?!?

    Original tests to / from the Armada with pfsense to PC/Acer were getting about 7. Mb/s

    Conclusions:
    1. My 3Com cards are rubbish:
    Under Ubuntu [on Acer] they consistently get <7Mb/s when set at 100Mb Full Duplex
    The Pfsense on Armade gets about the same but can't see what Duplex or Speed it is set. Some FreeBSD posts maybe indicate the driver needs updating to support Media so you can check / set these…..
    Under Fedora on Evo it is better [~16Mb/s] but still poor.
    2. The Toshiba Card only works at 10Mb. so not much good
    3. The Xircom Card doesn't work with pfsense or Ubuntu but does on Fedora
    This is strage. I'm used this under a manually built freebsd firewall ages ago and now it doesnt work? It got assigned ed driver but doesn't work. Recent Ubuntu is also having problems and although it is detected and set up it doesn't get any usable thrughput. My old Fedora build is fine and gets a 100Mb Full duplex connection. Throughput is still not great [12Mb/s]

    So should I persist with the laptops?



  • It sounds like pFsense just doesn't like the hardware.

    I also run my pFSense of a notebook, an old Compaq Armada E500 P3 900mhz with 384 megs of ram.

    I found a PCMCIA D-Link DFE-690TXD at Office depot; It was listed on the supported hardware list for pFSense.
    I use the D-LINK and the internal NIC.

    My firewall flies, I have a cable connection (Optimum Online). I've done some speed tests at speedtest.net and I get:

    10303 kbs down
    1381  kbs up

    that's about

    10.06152 megabit down
    1.348633 megabit up

    I think notebooks are great for running a firewall off of. Prior to this I ran m0n0wall straight from the CD on an old
    Compaq K6-2 PC. That processor was equal to a Pentium II.

    CPU power really isn't the issue. A firewall running on a Pentium 3 processor is basically overkill for any home broadband connection.

    For comparison my Cisco PIX 515E at work uses a Celeron 433mhz chip. We have roughly 60 users 15 of which
    use various market data applications and the PIX never passes 5% CPU utilization.

    Just my 2 cents.



  • Thanks for the info. I won't give up just yet.

    The PCMCIA cards I have clearly suck, but that might not be all as the RRD graphs are showing very high cpu when I did a long download making me wonder of the cards are CPU intensive. Is there any easy way to get a real-time CPU load graph so I can see what it's doing while I download? Where is the code for the real-time traffic graph?

    I've won an intel PCMCIA card on ebay so we'll see how that turns out.



  • I have see PC/MCIA adapter slow performance kill a really fast laptop.  I might would see if you could find a docking station for the laptop that supports a pci card put a dual port intel card in that.  That would help out greatly.

    I have over kill at home.  I have a Dell SC400 server with 2 GB adapters in it.  I created a vlan and had the server dsl modem on port two and the server on port 1.  I never see the server go over 15% even with 2 vpn tunnels maxed out.  Everything run's great for me.

    I have even run it on a dual 500 and a dual 266.  I have no issues on either.  In fact if you interested I make you a good deal on one of the two spares I have.  Let me know.
    RC



  • I got an Intel PCMCIA cardbus and this works much better.
    The card can get 95Mb/s on a good laptop and also on my P2 400 runninn pfsense.

    CPU is at about 75% though…..

    I just need to find another one now.

    So just need to issue a warning not to buy 3Com Megahertz PCMCIA cards!!!


Log in to reply