IPSec problem routing into tunnel



  • Hi,

    I am having problems getting IPSec routing working.

    1. I have pfSense 2.1-RELEASE running as a hub (site A) while connecting from a legacy router (site B) to the hub. The IPSec tunnel is set up properly, it is activated and working (green status) and I can ping from site B to hosts on site A correctly, but not vice versa. When the traffic is originating from site A, it is routed to the WAN interface but not into the tunnel.

    2. I have created a Rule on the IPsec interface:
      IPv4 *  *  *  *  *  *  none

    3. The phase 2 entry contains the network at site B:
      tunnel LAN 10.2.1.0/24 ESP 3DES SHA1

    3. I tried to setup a rule for outging NAT as indicated here https://doc.pfsense.org/index.php/Routing_internet_traffic_through_a_site-to-site_IPsec_tunnel but to no avail.

    Can someone please point me to the error in my setup?
    Thanks in advance for any help.

    Greetings,
    buv



  • You say legacy router. What model is it? Can you post it's configuration. Have you tried your setup without the outgoing NAT configuration you followed from that tutorial?



  • check phase 2 in side A


Log in to reply