Firebox X700 and IGMP Proxy issue



  • Hello,

    I hope someone can help me!
    Here is my problem: I am running a X750e box with a working config with IGMP Proxy working.

    So I want to set up a backup box, a X700 (512 MB RAM). The box ran with 2.0 and the IGMP stuff almost a year. So the box is OK.

    So far, so good. I want to use a hard disk, so I installed pfSense 2.1 on it. Everything went good so far. I configured the PPPoE and I can connect to the internet.
    I defined two VLANs (7 and 8 ) and an additional interface for IPTV. Now I have three interfaces: WAN, LAN and WAN_IPTV. I defined some rules for the IGMP Proxy on the interfaces LAN and WAN_IPTV in the fire wall.

    So, here comes the problem:

    when I am setting up the IGMP proxy upstream and downstream interfaces, the WEBGui throws division by zero errors. When the box is rebooted (console is connected) I see that even the three beeps could not be played because of an php error. Maybe some files are defect?!

    I tried three different HDs (10 GB, 40 GB and 60 GB), I installed an CF card (4GB) with the NanoBSD. No success. Every time the same error. Please see attachment.

    On the X750e the same config runs since two months.

    Does anyone have a clue?!

    Matthias
    ![Bildschirmfoto 2014-01-01 um 19.28.45.jpg](/public/imported_attachments/1/Bildschirmfoto 2014-01-01 um 19.28.45.jpg)
    ![Bildschirmfoto 2014-01-01 um 19.28.45.jpg_thumb](/public/imported_attachments/1/Bildschirmfoto 2014-01-01 um 19.28.45.jpg_thumb)


  • Netgate Administrator

    Hmm, interesting problem.
    I would assume you havd hit some bug that doesn't show except under specific circumstances. Presumably you may have setup thd x750e in some slightly different order. Have you tried setting up a new cf card on the x750e?
    One thing you could try is backup the config file from the x750e then manually edit it to change the interface references from sk0 to re0 etc. Then restore that to the x700. Of course there is pretty high chance of making some typo editing the file.  ;)

    Steve



  • Hello,

    I tried the following:

    restoring a X705e config with changed interfaces (sk0 -> re0 and sk1 -> re1): does not work, same behavior

    Then I copied selected parts from the X750e config to the x700 config (the igmp proxy settings): does not work.

    When I connect the WAN cable and connect to the provider something in the file structure gets corrupted: e.g. the following message was the last post from the box: can't exec getty '/usr/libexec/getty' for port /dev/console: Exec format error

    I will have a try with the 2.0 image and the same settings.

    Matthias



  • OK, after installing 2.0.3 everything runs without any problem!

    I made exactly the same configuration steps. This is so weird!?

    So, how can I run 2.1? Updating results with the same error….

    Matthias


  • Netgate Administrator

    Hmm. IPv6 issue perhaps?
    Doesn't ecplain why it's only broken on the X700. Some hardware off-loading not working with the Realtek NICs?

    Steve


Log in to reply