Problem with Dynamic DNS update -> Bug?



  • Hi there,

    I've had a problem on one of my pfSense boxes:
    Box had the WAN IP:  188.x1.10.xx
    By mistake I updated the Dynamic DNS record from another machine to: 82.x36.79.xxx

    So pfSense does no automatic update for this situation because pfsense does dynamic dns update if the IP on the (WAN) adapter hasn't changed.
    That I can understand. Perhaps it would be useful to compare once a day or something.. but that was mi fault.
    But I was very surprised that it didn't update after I "edited" the config and pressed the button "Save & Force Update". For me a "Force Update" shoud not only update the cache file, it should update also the entry at the remote site.

    Logfile:
    Jan 9 10:40:55 php: /services_dyndns_edit.php: phpDynDNS: updating cache file /conf/dyndns_wanfreedns'%dynamicdnsdomain%'0.cache: 188.x1.10.xx
    Jan 9 10:40:55 php: /services_dyndns_edit.php: phpDynDNS (%dynamicdnsdomain%): (Success) No Change In IP Address

    So there is no possibility to force a dynamic dns update to the remote dns server, if the adapter ip hasn't changed?

    As I wrote earlier I personally even thinking there should be a possibility that you can configure a "force update once a day".

    Regards



  • I have done this accidentally also. pfSense keeps thinking that whatever is in that cache file is the current IP address that the name translates to. I seems like it should actually translate the name out on the real internet and see what that value is, then if it is different from the interface's current public IP, make the change with the dynamic DNS provider. But, I guess, it takes time for a change at the dynamic DNS provider to propagate through the internet DNS and various caches. So the translated name might be a stale value, particularly if the customer has selected a long TTL for the name.
    I wonder how this can be done better?
    Delete the cache file from /conf, that will make it forget the last setting and it will have to do an update.


Log in to reply