Transparent Proxy: Squid allow Chrome to open gmail.com when it's blocked



  • Hi

    I have a very strange issue, I have blocked Webmail category on SquidGuard and I know when operating in transparent mode the only way to block the HTTPS connection is to block it in Squid. I did this, however and  Chrome somehow find it appropriate to display the page.

    In IE this is the page I get:

    ERROR

    The requested URL could not be retrieved

    –------------------------------------------------------------------------------

    While trying to retrieve the URL: http://www.gmail.com/

    The following error was encountered:

    • Access Denied.

    Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

    Your cache administrator is admin@localhost.

    This is the desired result and this does happen in Firefox and other browsers except for Google Chrome.

    Anyone had the same problem?


  • Rebel Alliance Developer Netgate

    If chrome is actually using the proxy, consult the proxy logs from the transaction to see just what server Chrome is hitting. It may be a special/different URL.



  • Hi

    The funny part is I am getting this in the logs:

    192.168.123.119 TCP_DENIED/403 1340 GET http://mail.google.com/ - NONE/- text/html
    192.168.123.114 TCP_DENIED/403 1336 GET http://www.gmail.com/ - NONE/- text/html

    But still it shows the page…

    Any other ideas?



  • No one…?



  • To those intressted, I managed to archive my goal by setting up an Firewall rule to REJECT the following Network range: 74.125.0.0/16


Log in to reply