No serial output (Watchguard)



  • I've tried to run pfSense on a Watchguard Firebox X1000, so I flashed pfSense (2.0.3 and 2.1) on a 4Gb Kingston CF card but when I boot the Firebox it doesn't give me any console output to configure it. Also when I tried to flash 1.2.3 to the card it gave me an error all the time so I decided to try a newer verserion.


  • Netgate Administrator

    The error was during writing the card?

    How is your serial console setup? Have you proven the cable with something else, say with the Watchguard OS?

    Steve



  • Yes the error was during the wrinting of the card.

    I've got an USB to Serial converter (FTDI chip) but because it has an male connector I used an db9 gender changer.
    All the pins on the gender changer are working but maybe the shield of the connector is the problem.
    this is the adapter that I used (mine is not branded Black Box): http://www.blackbox.com/Store/Detail.aspx/DB9-Gender-Changer-EMI-RFI-Shielded-Female-Female/FA445ĂR2
    Because the two screws prevented me from connecting to the Firebox I've unscrewd then thus there wasn't a connection between the front and back shield, I've trie to connect those with some metal wire but maybe that wasn't good enough.
    the USB to Serial converter is working fine, I can connect it to a Cisco switch and get all the Serial output.


  • Netgate Administrator

    The sheilding won't make much difference.
    It sounds like you're using the gender changer in place of a null modem cable. That's not going to work, you need the null modem to connect the pins correctly.

    Steve



  • Ok, thanks a lot for the help.


Log in to reply