Huawei e5331 3g wifirouter/usbnic with pfsense need some help



  • Anyone want to guide me on how to set it up with pfSense?

    what i want to do is to connect through the usb port.
    in windows its a storage device at first, after the driver install it brings  a virtual network adapter of some sort
    (HUAWEI Mobile Connect - Network Adapter)
    (usbcdcncm\Vid_12D1&Subclass_02&Prot_16)

    if i am not mistaken it would list in ifconfig?
    also in in /dev i get a few cuau, ppp wan mode through webui brought no success

    [2.1-RELEASE][admin@vmsense.localdomain]/dev(14): usbconfig -d 0.2 dump_device_desc
    ugen0.2: <huawei mobile="" huawei="">at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON
    
      bLength = 0x0012
      bDescriptorType = 0x0001
      bcdUSB = 0x0200
      bDeviceClass = 0x0000
      bDeviceSubClass = 0x0000
      bDeviceProtocol = 0x0000
      bMaxPacketSize0 = 0x0040
      idVendor = 0x12d1
      idProduct = 0x1506
      bcdDevice = 0x0102
      iManufacturer = 0x0002  <huawei>iProduct = 0x0001  <huawei mobile="">iSerialNumber = 0x0000  <no string="">bNumConfigurations = 0x0001
    
    [2.1-RELEASE][admin@vmsense.localdomain]/dev(15):</no></huawei></huawei></huawei> 
    

    ugen0.2: <huawei>at usbbus0
    u3g0: at uhub0, port1 addr 2
    umass0: at uhub0, port 1, addr2
    cd0:umass-sim0:0:0:0</huawei>


  • Netgate Administrator

    That looks like a device already in modem mode (PID: 1506).
    Exactly what devices do you have in /dev? Please copy and paste the output of:

    ls /dev/cu*
    

    What was the result of trying to setup a ppp interface? What did the ppp log say?

    Steve

    Edit: The Huawei E5331 is a mobile hotspot device. Is that what you have? How are you connecting to it?


Log in to reply