Uninstall snort.



  • It looks like my Snort stopped working. I tried to reinstall it, but this is what I get this:

    Removing package…
    Starting package deletion for snort-2.9.5.5-i386...done.
    Removing snort components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    Deinstall commands...

    ... and it hangs there. I have tried to reinstall/remove restart my router and re-do it again. Same...

    Please help.

    This is my pfSense version:

    2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:22 EDT 2013
    FreeBSD 8.3-RELEASE-p11



  • I have had the same problem twice.
    After doing some changes via SSH it was gone but unable to install Snort again.

    After some time I was done and just reinstalled my box and now it is working fine.
    p.s. Never had this problem in VMware, only on physical ones?



  • Can someone gives me a how-to about uninstalling packages manually?

    Thanks



  • @abadonna:

    Can someone gives me a how-to about uninstalling packages manually?

    Thanks

    You should install and remove packages through the GUI using the menu options under System…Packages.  The two posts here about a failure to remove Snort are unusual.  Were these originally fresh Snort installs on fresh 2.1 setups, or did these boxes get upgraded from 2.0.x and Snort got upgraded along as well?

    I will test the uninstall process just to be sure some bug did not inadvertently creep into some of the latest updates.

    Bill



  • I tested a Snort package uninstall operation on a virtual machine and it worked fine.  Here is the screenshot showing what you should see.  My VM test was with 64-bit pfSense, but the i386 should work exactly the same.

    It can take several seconds up to a minute or more for the uninstall to complete on a busy box (or one that is less powerful in terms of CPU horsepower).  Were there any log messages related to the uninstall attempt?

    Bill




  • @bmeeks

    Exactly the case.  My router was upgraded from 2.0.x. I tried to upgrade Snort, but not succeed…

    I know what I should see. The problem is, that what I should see vs what I can see is a bit different. The last command displayed on the screen says: "Deinstall commands..." and the process sits there forever.

    I am afraid I have tried all of my options from GUI...

    Please help.



  • @abadonna:

    @bmeeks

    Exactly the case.  My router was upgraded from 2.0.x. I tried to upgrade Snort, but not succeed…

    I know what I should see. The problem is, that what I should see vs what I can see is a bit different. The last command displayed on the screen says: "Deinstall commands..." and the process sits there forever.

    I am afraid I have tried all of my options from GUI...

    Please help.

    I suggest you do a backup of your configuration using the GUI (under Diagnostics…Backup/Restore).  After you verify the backup and have it safely saved off someplace, do a wipe and reload of pfSense from either a USB stick image or a CD-ROM.  As soon as you have a new 2.1 pfSense install laid down, import your saved configuration via the Diagnostics…Backup/Restore menu.  That should fix everything up.  My guess is you have something going on with the old TBZ packages from 2.0.x and the new PBI stuff in 2.1.

    Have you looked in the logs to see if any errors are being printed there?

    If you want to keep trying to salvage the current setup, you can SSH into the console and try your luck with the pbi_delete command.  This command should remove the PBI package:

    pbi_delete -v snort-2.9.5.5-i386
    

    Now if you also have remnants of the old 2.0.x TBZ package hanging around, there still may be issues.  If that is the case, try this command:

    pkg_delete snort\*
    

    Bill



  • Thank you Bill, I will try it over the weekend.


Log in to reply