My Wi-Fi Adapter isn't recognized



  • I finally got PF sense working and I love it but I can't get wireless! I built my own router and I installed the TP-LINK TL-WDN4800 Dual Band Wireless adapter card into the PCI Express X16 slot which I understand is backwards compatable with PCI Express X1. Anyway, when I try to assign an interface for it to begin setting up my wireless I can't because it isn't recognized by pfSense. Is this wireless adapter not compatible with it?

    For reference here's the link to the card: http://www.newegg.com/Product/Product.aspx?Item=N82E16833704133



  • It should work in 2.2.



  • Is there any news when 2.2 will be coming out because right now I'll be without Wi-Fi?



  • @hikaru12:

    Is there any news when 2.2 will be coming out because right now I'll be without Wi-Fi?

    4-6 months would be my guess but the official position is probably "when it's ready", just like 2.1.

    Use an access point (or an old router with NAT, DHCP, etc. disabled) for your wifi.



  • Sounds good.

    EDIT: I wasn't able to get it working. My devices would recognize the Wi-Fi network but it wouldn't broadcast internet. I connected the old router to the switch and connected it to it's WAN and then tried connecting to it's LAN ports and it was never able to broadcast a signal. Now I'm stuck without Wi-Fi. I guess I should have checked the comparability before buying that particular adapter.

    Edit 2: Missed the part about the router still using DHCP and stuff. That would explain why connecting it to my switch would create conflicts and prevent other devices on my LAN from accessing the network. Off to buy an access point then.



  • If you want to use your old wifi router as an access point, as Jason said disable NAT and DHCP on the wifi router and give it its own (probably static) address on your LAN.  However, don't connect its WAN port to anything - use a LAN port to connect to your switch/pfSense LAN.



  • Thanks for the advice. Unfortunately, because my old router is P.O.S. - it doesn't give me the ability to disable the NAT or maybe I'm just not seeing it. It's an old Linksys WRT54G2.


  • Netgate Administrator

    I would be amazed if it didn't have those options.

    Depending on which hardware revision on that router you have you may be able to put OpenWRT or DD-WRT on to it to unlock some more options. You shouldn't need to do that though.

    Steve


Log in to reply