Pfsense n00b requesting help



  • Hello everybody!

    I have a problem setting up pfsense.
    Here's what I have to work with: Ubuntu 13.10, running pfsense in virtualbox.
    I have a dedicated intel dual nic in dedicated passthrough to pfsense, so the host does not interfere.

    pfsense sees the nics, and correctly registers link up/down.

    I set one port for WAN, one for LAN. I connected the lan port directly to the other gbit nic in my ubuntu machine, which uses dhcp to get an ip.

    I set the lan ip to 10.0.0.1, 255.255.255.0, dhcp server on.
    I set the wan ip to dhcp.

    Lan problem: no connection to pfsense at all, no ip addresses are given out, using static ip addresses in the range I selected also does not solve the problem.

    Wan problem: no ip address received from DD-wrt box (which will eventually be replaced once pfsenseis up and running), it's also not on dhcp clients list in DD-wrt. Setting static ip within the range of teh dd-wrt box still doesn't allow me to ping anything.

    Since there is no connection either wan or lan, I can't connect to webui to check the logs.

    what else could I do?


  • LAYER 8 Global Moderator

    You sure you didn't reverse the nics, and what pfsense thinks is lan is really your wan, and what it thinks is your wan is really connected to your lan.

    That would explain what your seeing.

    I run pfsense virtual (esxi) but one way I validate which nic is which to pfsense is actually set the mac on the virtual nic that pfsense sees, so I know for sure which one is which and can match up virtual to physical, etc.

    If your doing passthru - I would validate which one is which on the mac address.



  • I got it to work eventually, but not with passthrough, it just wouldn't go.

    I used bridge mode, but with ipv4 disabled for those 2 nics at the host, so that there is no direct connection from the host to the internet, only through pfsense. Too bad passthrough didn't work, would've been better.


Log in to reply