Ntpd stops after link-down and never restarts



  • There was another thread around discussing ntpd crashing like this  (link):

    Jan 6 23:37:25 kernel: pid 37798 (ntpd), uid 0: exited on signal 11 (core dumped)

    And I can say with some confidence that I am experiencing this behavior when I have a link-down event occur.  When the link-up event happens, ntpd does not restart.  I have to manually go into pfSense to restart it.

    
    Dec 24 14:48:31	php: rc.newwanip: rc.newwanip: Informational is starting em3.
    Dec 24 14:48:29	check_reload_status: rc.newwanip starting em3
    Dec 24 14:47:20	kernel: pid 37202 (ntpd), uid 0: exited on signal 11 (core dumped)
    Dec 24 14:47:04	php: rc.filter_configure_sync: Could not find IPv4 gateway for interface (wan).
    Dec 24 14:47:04	php: rc.start_packages: Restarting/Starting all packages.
    Dec 24 14:47:04	php: rc.dyndns.update: DynDNS (xxx.dyndns.org) There was an error trying to determine the public IP for interface - wan(em3). Probably interface is not a WAN interface.
    Dec 24 14:47:04	php: rc.dyndns.update: DynDns (xxx.dyndns.org): IP address could not be extracted from checkip.dyndns.org
    Dec 24 14:47:03	php: rc.dyndns.update: DynDNS (Home) There was an error trying to determine the public IP for interface - wan(em3). Probably interface is not a WAN interface.
    Dec 24 14:47:03	php: rc.dyndns.update: DynDns (Home): IP address could not be extracted from checkip.dyndns.org
    Dec 24 14:47:02	check_reload_status: Reloading filter
    Dec 24 14:47:02	check_reload_status: Starting packages
    Dec 24 14:47:02	php: rc.newwanip: pfSense package system has detected an ip change 74.90.xxx.xxx -> 192.168.100.20 ... Restarting packages.
    Dec 24 14:47:01	php: rc.newipsecdns: IPSEC: One or more IPsec tunnel endpoints has changed its IP. Refreshing.
    Dec 24 14:47:00	php: rc.newwanip: Creating rrd update script
    Dec 24 14:47:00	php: rc.newwanip: Resyncing OpenVPN instances for interface WAN.
    Dec 24 14:47:00	php: rc.newwanip: Ignoring IPsec racoon daemon reload since there are no tunnels on interface wan
    Dec 24 14:46:59	php: rc.newwanip: DynDNS (xxx.dyndns.org) There was an error trying to determine the public IP for interface - wan(em3). Probably interface is not a WAN interface.
    Dec 24 14:46:59	php: rc.newwanip: DynDns (xxx.dyndns.org): IP address could not be extracted from checkip.dyndns.org
    Dec 24 14:46:58	php: rc.newwanip: DynDNS (Home) There was an error trying to determine the public IP for interface - wan(em3). Probably interface is not a WAN interface.
    Dec 24 14:46:58	php: rc.newwanip: DynDns (Home): IP address could not be extracted from checkip.dyndns.org
    Dec 24 14:46:58	php: rc.newwanip: MONITOR: GW_WAN is down, removing from routing group GWDStatic
    
    

    Is this proper behavior, or is there something wrong?  What's also interesting is that I have ntpd set to use a different WAN gateway.  ntpd uses WAN2 as its primary gateway, not WAN.  However, when WAN goes down, it takes ntpd down with it.  Possibly this is happening when all services reload, and that would indicate another problem.

    Failover works flawlessly with all other services except for ntpd.
    ![Screen Shot 2014-01-15 at 11.20.50 AM.png](/public/imported_attachments/1/Screen Shot 2014-01-15 at 11.20.50 AM.png)
    ![Screen Shot 2014-01-15 at 11.20.50 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2014-01-15 at 11.20.50 AM.png_thumb)


Log in to reply