Found a bug with TXT records?



  • I was setting up a mail server and I needed to add a TXT record to the firewall, running pfsense 2.1

    In the 'Services' -> 'DNS forwarder' -> 'Advanced' field I wrote this line:

    txt-record=example,'v=spf1 mx -all'
    

    And when I check from the console this is what I get:

    ;; ANSWER SECTION:
    example.com.		1	IN	TXT	"v=spf1 --mx ---all"
    

    I tried adding it manually using 'Diagnositics' –> 'edit file' and entering filename '/usr/local/etc/dnsmasq.conf'

    txt-record=example.com,v=spf1 mx -all
    

    After restarting the output is as expected:

    ;; ANSWER SECTION:
    example.com.		1	IN	TXT	"v=spf1 mx -all"
    


  • The code that parses the text in the Advanced box allows the parameters to be separated by spaces. It puts "–" in front of every space-separated chunk of text. That does not work in your case! The code has to either be smarter and parse the input more (like ignoring space inside of quoted strings) or disallow space-separated parameters - make people put a new-line between every parameter.


Log in to reply