Disable dhcpv6



  • I have RA for LAN interface set to Route Only, but the dhcpv6 server keeps starting even though it is not enabled. This is causing problems with my primary dhcpv6 server (different machine). How can I disable dhcpv6 from starting?



  • I had the same issue. I found that when I disable NAT on router with static IPv6 on LAN interface then Router Advertisement is active even when it should not be…

    I solved it using Shellcmd package. It is not nice, but following shellcmd will do the work:

    pkill radvd
    


  • Look at Status: Services.



  • radvd and dhcp6 aren't even close to the same thing. Not sure what OP's issue was 2 years ago, dhcpd6 only starts where enabled, or where using 'track interface'. radvd has no relation to dhcp6. Doing a pkill of radvd isn't going to even work around the issue effectively, it'll be restarted by a variety of things because something is configured that makes it start.

    Rudolf: what exactly do you have configured for RAs? Are you using "track interface"?



  • Hi cmb,

    I configured only a few things – all other options are in default.

    Configured:

    • WAN (hn0): Static IPv4, Static IPv6 (in unique local fd00::/8 range) + gateway to another IPv4 / IPv6 router

    • LAN (hn1): Same, without GW

    • NAT: Disabled

    • FW: Pass all IPv4/6 on WAN and LAN (I’m building testing environment so security isn’t my concern right now and I’m going to add rules later)

    • DHCPv4/6 and Router Advertisement: Disabled

    • DNS Resolver: Disabled

    basically – it’s just a router…

    Windows Servers that are in several subnets and should communicate each other get IPv6 addresses from pfSense. That’s problem since Windows Servers (their interfaces are in default so RA is enabled) have configured static IPv4 and 6 (fd00::/8).

    When radvd is up then Windows Server gets another IPv6 and I can see lease in "Status: DHCPv6 leases" section. Windows Server then tries to communicate with another in different subnet using IPv6 from DHCPv6 and that’s not possible since another router doesn’t have correct static route (IP from DHCPv6 has different subnet).


Log in to reply