Speedtest.net Upload Test Fails with Squid/SquidGuard Enabled



  • For some reason, the Upload test times out when SquidGuard is enabled.  I've searched and only managed to come up with this for a solution to this problem was a suggestion to edit squidlconf and add:

    never_direct allow all

    to the cache_peer block.

    How do you do that in the pfSense GUI?  I'm hesitant to edit the file directly, as most webGUI open-source apps I've user will stomp on the file if you edit it by hand.  Someone else had this exact same problem last April, but nobody replied and he never came back with a solution.



  • @KOM:

    For some reason, the Upload test times out when SquidGuard is enabled.  I've searched and only managed to come up with this for a solution to this problem was a suggestion to edit squidlconf and add:

    never_direct allow all

    to the cache_peer block.

    How do you do that in the pfSense GUI?  I'm hesitant to edit the file directly, as most webGUI open-source apps I've user will stomp on the file if you edit it by hand.  Someone else had this exact same problem last April, but nobody replied and he never came back with a solution.

    1. Please run and paste output of pkg_info and pbi_info so we can see what package versions you are working from.

    2. What version of pFsense 2.1? Nanobsd?

    3. Is it a fresh install or have you upgraded?

    4. Have a screenshot of what happens with speedtest.net?

    5. Is there anything in the logs when it blocks the upload test?



  • 1. pkg_info:

    bsdinstaller-2.0.2013.0911 BSD Installer mega-package
    gettext-0.18.3



  • @KOM:

    1. pkg_info:

    bsdinstaller-2.0.2013.0911 BSD Installer mega-package
    gettext-0.18.3

    Going to need the rest of the information still ;)


Log in to reply