No automatic Outbound NAT



  • Hi guys,

    This question is probably extremely trivial, but I hope you can help me with this…

    I have re-installed my pfSense (now it is on  2.1-RELEASE (amd64) built on Wed Sep 11 18:17:48 EDT 2013 FreeBSD 8.3-RELEASE-p11) and everything works nicely. Before I had a problem with snort. (https://forum.pfsense.org/index.php/topic,71370.msg389803.html). Not anymore.

    Before the re-installation, when I went to Firewall --> NAT --> Outbound, and I clicked on "Manual Outbound NAT rule generation" the  "Mappings" were populated automatically. Not anymore :-(

    I have checked System --> Advanced --> Firewall and NAT and I have "Enable automatic outbound NAT for Reflection" and "Enable NAT Reflection for 1:1 NAT" ticked, and my "NAT Reflection mode for port forwards" is set to: Enable (Pure NAT).

    And it still does not create the Outbound NAT automatically...

    Please help.

    A.



  • Well, it's not hard to create rules for outbound NAT. Use your WAN interface, source any destination not your internal ranges, use interface address, boom, done. What are you trying to achieve outside of standard NAT?



  • to generate the outbound nat AGAIN, the list of nat rules needs to be empty before you re-enable AON



  • @timthetortoise, You are right, it is not difficult to do it manually. The case is, it was working before, now it stopped. I'd like to understand why, and bring this feature back.

    @heper, It was empty. I even emptied it after reading your post, and it does not recreate it automatically.


  • LAYER 8 Global Moderator

    Not sure where helper got the idea that manual rules have to be empty in the first place?  When you switch back to automatic, the manual rules are not even looked at.

    You can verify that for yourself with a simple look see with  pfctl -s nat

    So in manual mode you will notice very specific rules
    pfctl -s nat
    no nat proto carp all
    nat-anchor "natearly/" all
    nat-anchor "natrules/
    " all
    nat on em1 inet from 192.168.1.0/24 to any port = isakmp -> 24.13.xx.xx static-port
    nat on em1 inet from 192.168.1.0/24 to any -> 24.13.xx.xx port 1024:65535
    nat on em1 inet from 192.168.2.0/24 to any port = isakmp -> 24.13.xx.xx static-port
    nat on em1 inet from 192.168.2.0/24 to any -> 24.13.xx.xx port 1024:65535
    snipped the rest xx out part of my wan address.

    Now look at same rules while in automatic mode

    pfctl -s nat
    no nat proto carp all
    nat-anchor "natearly/" all
    nat-anchor "natrules/
    " all
    nat on em1 inet from <tonatsubnets>port = isakmp to any port = isakmp -> 24.13.xx.xx port 500
    nat on em1 inet from <tonatsubnets>to any -> 24.13.xx.xx port 1024:65535
    no rdr proto carp all

    I assure you my manual nats are still there and what do you no the nat rules changed to generic rules using <tonatsubnets>So what I suggest you do is take a direct look at what your nat rules are via  pfctl -s nat when you switch between manual and automatic.


    </tonatsubnets></tonatsubnets></tonatsubnets>


Log in to reply