Wireless N card to host wifi



  • Im looking for a good wireless N card for my new PFsense setup. I was wondering if any one has one they can recommend.


  • Netgate Administrator

    The only 802.11N cards you will get to run as an access point are selected Atheros models but even then they will only run at 802.11G speeds. There is no support for 802.11N speeds in pfSense at all  :( (coming in 2.2). If you need that use an external access point. There are a number of advantages to doing that anyway.

    Steve



  • Atheros 9280, got 2 of those.

    One is giving me often errors (ath0: stuck beacon; resetting (bmiss count 4)), other has issues with signal strength (signal extremely weak).
    "Stuck beacon" can be avoided by choosing "loner" channel very different from channels that other AP's in same area use. Other than that issue, it's working very well with pfSense

    First is straightforward PCIe device, second card is notebook wifi installed on PCIe/miniPCIe adapter card.

    It let's me choose N channels but got only phone for wifi, no clue as to created wifi is really "N"


  • Netgate Administrator

    You can reduce the stuck beacon errors if you're in a congested area by adding the following to the system tunables:
    Tunable name: hw.ath.bstuck
    Description: Whatever you want
    Value: 8

    I have an earlier Atheros card and adding that prevented my logs being filled with stuck beacon errors though those errors never had much effect on the wifi.

    The Atheros driver has the ability to choose which of the antenna connectors it uses so if you don't have them all connected (I have only 1 antenna) then make sure it's set correctly otherwise the range will be much reduced.

    Steve


  • Banned

    @stephenw10:

    You can reduce the stuck beacon errors if you're in a congested area by adding the following to the system tunables:
    Tunable name: hw.ath.bstuck
    Description: Whatever you want
    Value: 8

    That exactly did not work for me nor did it solve anything, plus the problem was so bad I got a kernel panic multiple times. Issue traced down to severe noise from wireless TV signal transmitter. The wifi drivers seriously are a piece of junk on FreeBSD.


  • Netgate Administrator

    I won't argue with you there.  ;) Though they are much improved in 10.
    Like I say it wan't actually causing me any problems besides spamming the logs.

    Steve



  • @stephenw10:

    You can reduce the stuck beacon errors if you're in a congested area by adding the following to the system tunables:
    Tunable name: hw.ath.bstuck
    Description: Whatever you want
    Value: 8

    I have an earlier Atheros card and adding that prevented my logs being filled with stuck beacon errors though those errors never had much effect on the wifi.

    The Atheros driver has the ability to choose which of the antenna connectors it uses so if you don't have them all connected (I have only 1 antenna) then make sure it's set correctly otherwise the range will be much reduced.

    Steve

    Thanks

    Replacing antennas made no difference. I use 2 and have 6 for spare to choose from, incl. one directional antenna. But thanks for the tunable.


  • Netgate Administrator

    Just to be sure you understood, I'm refering to this section of the interface setup:

    Antenna settings: 	Diversity	   	Transmit antenna	   	Receive antenna
     	 	 	off 	 	 	#1 	 	 	 	 #1
    
    Note: The antenna numbers do not always match up with the labels on the card. 
    

    If you have either Rx or Tx set to use a connector on which there isn't an antenna range will obviously be much reduced. Note comment about labels also.
    I have diversity disabled because I'm only using one antenna.

    Steve



  • Hmm. I tried both ways. Transmit with #1, Receive with #2 and vice versa. And had both physically connected to the connectors as well.

    What I did not think to try was with one antenna..

    Since it was wifi card taken from broken notebook (with its antenna hidden inside/behind the LCD screen), I figured that perhaps the electrical resistance of the antennas I tried to use were not correct. And left it at that. Was easy enough getting another atheros.


  • Netgate Administrator

    I'm only using #1 for both because I only have one antenna connected. Before I realised this one of them was to #2 and, perhaps unsurprisingly, the range was terrible.

    Steve


  • Banned

    Now that you mention the diversity… have you verified the settings actually have any/intended effect? Because that's definitely not what I have seen with multiple CM9/CM10 cards and definitely not those that are described in the GUI hints. No matter what I set, I end up with this in the end:

    
    dev.ath.0.txantenna: 0
    dev.ath.0.rxantenna: 2
    dev.ath.0.diversity: 1
    
    

  • Netgate Administrator

    Working fine for my card. It's a bit older than many.

    dev.ath.0.%desc: Atheros 2413
    
    dev.ath.0.txantenna: 1
    dev.ath.0.rxantenna: 1
    dev.ath.0.diversity: 0
    
    

    Also I know the antenna selection is working because if either are set #2 (or Default or Auto) then the range is reduced dramatically.

    Steve


  • Banned

    @stephenw10:

    Also I know the antenna selection is working because if either are set #2 (or Default or Auto) then the range is reduced dramatically.

    Well yes, that's how I figured out it has no effect here because no matter what I set nothing improves or gets worse. :D