Set mtu 1492 on WAN



  • i use PPPoE on WAN
    either a realtek or a marvell card
    on WAN i cannot set mtu to 1492 and set the Speed and duplex field (it does not appear there)

    on LAN everything works as expected (mtu and Speed and duplex)

    WAN
    $ ifconfig re0
    re0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=219b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,wol_magic>inet6 fe80::21f:d0ff:fe50:113d%re0 prefixlen 64 scopeid 0x2
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet autoselect <flowcontrol>(1000baseT <full-duplex,flowcontrol,rxpause>)
    status: active

    LAN
    $ ifconfig msk0
    msk0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    options=c011b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,tso4,vlan_hwtso,linkstate>inet 192.168.1.1 netmask 0xffffff00 broadcast 192.168.1.255
    inet6 fe80::250:43ff:fe00:22bc%msk0 prefixlen 64 scopeid 0x1
    nd6 options=1 <performnud>media: Ethernet autoselect <flowcontrol>(1000baseT <full-duplex,flowcontrol,rxpause,txpause>)
    status: active</full-duplex,flowcontrol,rxpause,txpause></flowcontrol></performnud></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,tso4,vlan_hwtso,linkstate></up,broadcast,running,simplex,multicast></full-duplex,flowcontrol,rxpause></flowcontrol></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,tso4,wol_magic></up,broadcast,running,simplex,multicast>


Log in to reply