PPPoE with dynamic IP do not automatically reconnect



  • Hi,

    I have a pfSense 2.1 amd64 release that has two wan configured. An static IP connection (now on WAN1) as a default gateway used for the servers and a dynamic IP connection through PPPoE (now in WAN2) that I use to web browsing and everything else. The particular configuration that I have is that I had configured a gateway group to use the WAN1 as a backup of the WAN2.

    The ISP change the IP address of the WAN2 every 12 hours and the issue that I have is that the pfSense do not reconnect when this happens. If I disable and re enable the interface manually the WAN2 connection is restored.

    Do you have any idea of why is this happening?

    Regards!



  • It seems to be an issue of apinger that has troubles in this version of pfSense. I've configured cron to reset the apinger every 5 minutes and it seems to work. It's not the solution but at least a workaround.

    Here is the script that I execute with cron:

    
    #!/bin/sh
    killall apinger
    sleep 3
    /usr/local/sbin/apinger -c /var/etc/apinger.conf
    
    

Log in to reply