Pfsense stops after "Boot: F1"



  • I recently upgraded the hard drive in my pfsense box from a 6GB to a Maxtor 160GB HDD, but now pfsense doesn't boot anymore. It says

    F1 pfsense
    
    F6 PXE
    Boot: F1
    \
    

    And nothing happens after that. The same problem was discussed here: https://forum.pfsense.org/index.php?topic=13671.0 but nothing helped. I disabled num lock, disabled pack mode and jumpered the HDD to Master. I also tried to enable legacy IDE mode, but I couldn't find the option in my BIOS. (The mainboard has SATA and IDE)

    I hope anyone can help me



  • Not sure if you solved this yet, but it is because of a large partition on the drive.  During setup if you do a custom and set the install partition to around 32GB to 120GB that will resolve this issue.



  • I partitioned it like this http://imgur.com/tCVA6Il and it helped a bit. Now it gets stuck at```
    F1 pfSense
    F2 pfSense

    F6 PXE
    Boot: F1

    BTX loader 1.00 BTX version is 1.02
    Consols: internal video/keyboard
    BIOS drive C: is disk0
    /



  • The installation seems to work properly. When I put the hard drive in another PC without reinstalling it, it boots perfectly.


  • Netgate Administrator

    Probably a bios issue with the much larger HD. Are you on the latest bios for your board?

    Try setting the root partition at <4GB. That can help in some buggy situations.
    https://doc.pfsense.org/index.php/Boot_Troubleshooting#BIOS.2FDisk_Errors

    Steve



  • i encountered the similar issues with some older machines. some bioses have a feature called something like "legacy usb support" or similar. try disabling this before you install pfsense. this shouldn't have enabled by default therefore you probabily can just load your bios default settings and save.
    the other thing what may help: remove completely the existing partiton information and prepare your hdd using freebsd livecd and "freebsd way". change the partition type to 12 (or 165) and create slice(s) etc. it should help, at least helped me..



  • The answer is - BTX loader misbehaving (obsolete) ATA standart. The solution is to switch SATA (IDE ? ) to RAID JBOD if motherboard supports such configuration.



  • I'm requesting to make this topic steaky because it is really hard to find an answer considering the topic.
    Thank you.


Log in to reply