Captcha não aparece com Squid



  • Quando configuro o proxy nas máquinas e tento acessar sites que exibem o CAPTCHA o mesmo não aparece, quando desabilito o proxy aparece normalmente.
    O site que preciso está liberado na regra que foi criada, e chega abrir a página principal, mas ao acessar o local onde deveria aparecer o CAPTCHA, o mesmo não aparece! O site que estou tentando é o sintegra.gov.br.



  • Amigo, sites do governo não gostam muito de proxy.

    Sugiro que crie uma aliase com todos os endereços de sites do governo e crie uma regra em que estes sites não passam pelo proxy
    também coloque os endereços da whitelist e não usar cache.

    lembre-se sobre a ordem das regras, o pfsense lê de cima para baixo.

    Procure no fórum sobre sites do governo ou conectividade social que você encontrará muito conteúdo interessante.

    att.



  • @guitarcleiton:

    Amigo, sites do governo não gostam muito de proxy.

    Sugiro que crie uma aliase com todos os endereços de sites do governo e crie uma regra em que estes sites não passam pelo proxy
    também coloque os endereços da whitelist e não usar cache.

    lembre-se sobre a ordem das regras, o pfsense lê de cima para baixo.

    Procure no fórum sobre sites do governo ou conectividade social que você encontrará muito conteúdo interessante.

    att.

    OK vou testar!



  • O pluging firebug do firefox habilitado na aba rede pode te ajudar muito a identificar o que não está passando pelo proxy.



  • Oi Felix_BH. Passei pelo mesmo problema em um cliente.

    Como solução foi necessário liberar no proxy para o usuário as seguintes url:

    api.recaptcha.net 
                                              www.google.com

    Apos isso não tive mais problema com a geração de imagem no captcha.

    Abraço.



  • @platinicaldas:

    Oi Felix_BH. Passei pelo mesmo problema em um cliente.

    Como solução foi necessário liberar no proxy para o usuário as seguintes url:

    api.recaptcha.net 
                                              www.google.com

    Apos isso não tive mais problema com a geração de imagem no captcha.

    Abraço.

    Estou com este mesmo problema, porém no meu caso o recaptcha não carrega apenas.
    Utilizo a versão 2.3.2 com squid proxy transparente com interceptação SSL.



  • Pessoal estou passando pelo mesmo Problema, onde uso a seguinte, uso squid proxy não transparente junto com squidguard, onde  eu bloqueio tudo, e vou liberando aos  poucos, alguem pode me ajudar ?