HAVP for pfSense 2.1



  • When there there be a compatible HAVP for pfSense 2.1, mulitple people have tried the current package for 2.1 an found its buggy had has issues when pfsense restarts. With lots of research something that eludes to the fact the current package places files in the wrong directory for 2.1 and the havp.sh script causes the services to have issues on a restart. Thanks, just wondering if anyone had any insight.



  • This won't help you, but I had to remove HAVP from my 2.1 pfsense.

    The issues I was having were too great for me to deal with, I am new to pfsense.  HAVP was letting the virus test file through the proxy in .txt form, it would block the test file in .com or .exe form without bringing the HAVP screen up and was intermittently blocking sites that were known to be clean.  after 2 frustrating weeks of trying to configure it to do what I wanted, I gave up.



  • I didn't remove mine, but disabled it… for different reasons.

    To get it working I went back to a 2.0.3 build and installed all packages and updated to 2.1.  HAVP worked well for blocking or not as needed but the latency on streaming video was excessive.  I tried everything I could find here but in the end just disabled it.    Will look at the Squid with ClamAV when its more stable



  • I had HAVP blocking all files, but like was stated, the latency was high with just HAVP alone, when I installed Squid in transparent mode and set HAVP as the parent proxy the latency went back to normal since HAVP then scans the squid cache. I have HAVP now disabled because every time pfSense would restart HAVP would have difficulty starting the service without a clamav error of some sort and would completely kill internet traffic when it was not started.



  • Same here
    I used it for a while until i got blocked http traffic , since its service kept failing.

    But it would be nice to have new any  AV on http ,ftp even smtp



  • I too had a problem with pfS2.1-x64 with clamAV not starting and havp crashing.  After reading other posts I tried using the command "freshclam" from the console and got a gid/uid error for the /var/db/clamav directory.  I issued the command "chmod -R 0777 /var/db/calmav" and tried freshclam again with success.  I then issued the command "service calmd start" with success.  It has now been running for 4 hours. . . After posting this message I got to looking at the /var/db directory and noticed that most directories listed have a root:wheel ownership as opposed to clamav which has a havp:havp ownership.  I hope this info might be of some help.


Log in to reply