Apinger and multiWAN



  • Dear forum users,

    I have this set up. three WAN interfaces configured to get each an internet connection to the same ISP. all of them have successfully connected to the ISP and all of them have the same gateway.. So i have several questions:

    1. I've noticed that the load balancing works since sometimes in the same computer I get different public IPs (whatsmyip.com). Well at least that's what i consider a round robin connection and in consequence a load balancing set up. Is this alright?

    2. Now, I think that apinger or the PPPoE script have a bug somewhere, since i have the following scearios:

    -apinger displays a latency issue with one of the three gateways -> go to diagnostics and perfom a traceroute and a ping to the same host to confirm… This works perfectly and matches apinger results

    -apinger display a gateway down- this is where the problem is. Cause i go again to diagnostics and perform a ping on the same gateway and to the same host. It shows that the gateway is not down.....So i go to gateways change the monitor IP to another public DNS (the ISP gateway supports ICMP but since all three are same gateway, Pfsense asks for different monitor ips) and suddenly it works and shows a online status....... :(

    Im starting to have a feeling that apinger is not reliable, and the biggest problem is that since it is not reliable it messes with my merged ADSL by taking the connection out of the group.

    Ive read in blogs that Pfsense might have a bug with the PPPoE connection... BTW im running (2.1-RELEASE (i386) )

    Comments?
    suggestions?

    anything will be appreciated. Thanks in advance!


  • Rebel Alliance

    A bit late, but for what it might be of help…...  :P

    Have you defined a different Monitor IP for each GW ?  https://doc.pfsense.org/index.php/Multi-WAN_2.0#Monitor_IP

    Have you tried with the 2.1.1-PRERELEASE  version ? https://forum.pfsense.org/index.php/topic,71546.0.html





  • Dear PTT,

    Thanks for the reply :)
    2.1.1 already out!!!
    Im working on a production server and no chance of testing or at least very difficult since Im working remotely, but ill read carefully the comments on new release. ill have to go slow on critic changes!

    The monitor IPs are different DNS servers:
    8.8.8.8 google primary
    8.8.4.4 google secondary
    208.67.222.222 and Open DNS

    apinger works by refreshing the service every time it shows as offline, adding the cron job every 5 minutes works (thanks krylou, I had this test going already :)) until at some point a pending status drops the gateway… changed the time to 10 mins and the same issue happens.....

    It sad that a small detail on a side service is causing so much trouble on a incredible project, hopefully this will get solved thanks to the gurus working there!!

    Any suggestion is welcome :)



  • Sorry to bring back these old posts but desperately trying to get attention of the devs.

    This issue still persists in 2.1.3!

    Applying the 5-minutes apinger restart cron job doesn't really solve the issue. This is causing serious problem for many multi-WAN users.



  • Unfortunately,it is still in 2.1.5!