SYNC interface for CARP not working



  • I have CARP up and running, but it is synchronizing via LAN. I have a dedicated SYNC interface set up, the interfaces are up, and connected via a crossover cable. But I cannot make it work - master fails to access backup machine to synchronize. It turns out the machines cannot even ping each via the SYNC interfaces / subnet.

    Interface set up:
    Master: 192.168.4.1/24
    Backup: 192.168.4.2/24

    Firewall rules on the SYNC interfaces of both machines are like in the attachment.

    Where am I going wrong? I also saw this thread with a similar issue, but no resolution.
    ![pfsense - Firewall: Rules: Edit - Mozilla Firefox_189.png](/public/imported_attachments/1/pfsense - Firewall: Rules: Edit - Mozilla Firefox_189.png)
    ![pfsense - Firewall: Rules: Edit - Mozilla Firefox_189.png_thumb](/public/imported_attachments/1/pfsense - Firewall: Rules: Edit - Mozilla Firefox_189.png_thumb)



  • This turned out to be a simple mistake on my part combined with a UI problem.

    When creating the SYNC interfaces - I had clicked "Insert my local MAC address" in the MAC address field, thinking it would populate using the NIC's MAC address, not the machine I am logging in from. When I realized it didn't, I blanked the field, assuming it would revert to its own MAC if the field was blank.

    Not so. My originally entered MAC address remained with the interface even after the field was blanked and saved, resulting in a loop.

    Changing the MAC addresses such that they do not conflict solved the issue.


Log in to reply