1.2rc3 ACPI Issues on i865 Machines



  • Hello, All,

    I have 1.2rc3 running on a bunch of different machines, but one set in particular now appear to be having ACPI-related issues.
    I am using several HP dx2000 business desktop microtower boxes, as they are (1) small, (2) quiet and (3) freely available in my employer's inventory.

    Although things were running perfectly fine with 1.2rc2, updating to 1.2rc3 causes the machine to hang on bootup. 
    I've been running 1.01 for a long time on one of them (since its release, still untouched) and the whole line of 1.2 betas and rc's on several others.

    Here is the text from the boot:

    
    /boot/kernel/acpi.ko text=0x435f8 data=0x23c0+0x10f0 syms=[0x4+0x7ba0+0x4+0x]
    Copyright (c) 1992-2007 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    	The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 6.2-RELEASE-p8 #0: Wed Nov  7 18:38:17 EST 2007
        sullrich@builder6.pfsense.com:/usr/obj.pfSense/usr/src/sys/pfSense.6
    Timecounter "i8254" frequency 1193182 Hz quality 0
    CPU: Intel(R) Pentium(R) 4 CPU 2.80 GHz (2800.48-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0xf34   Stepping = 4
      Features=0xbfebfbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x441d<sse3,rsvd2,mon,ds_cpl,cntx-id,<b14>>
    real memory  = 527695872 (503 MB)
    avail memory = 506957824 (483 MB)
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
    acpi0: <compaq intel865="">on motherboard</compaq></sse3,rsvd2,mon,ds_cpl,cntx-id,<b14></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe> 
    

    It never makes it any farther than that.  This also happens when booting directly off the 1.2rc3 LiveCD without any config present.
    Rebooting, and manually selecting to disable ACPI–boots and works fine (both off the hard disk install, and from the LiveCD).

    Details on the machines:

    HP dx2000 business desktop microtower
    P4/2.8 GHz
    2x256 MB PC2700
    BIOS on machine in question is 1.16; some have 1.14-1.16 (last release was 1.17; will try that and update)

    Question:

    For the time being, how can I manually configure the boxes to boot with ACPI disabled, so I don't have to be at the machine when rebooting it?

    Is there anything else I can provide that may prove helpful?

    Thanks



  • @strick1226:

    For the time being, how can I manually configure the boxes to boot with ACPI disabled, so I don't have to be at the machine when rebooting it?

    http://devwiki.pfsense.org/BootOptions



  • CryHavok,

    Thanks!  It worked a charm!!!


Log in to reply