RRD Not Working and RRD Lost After 2.0.3 -> 2.1 Upgrade



  • I've made the upgrade on several machines (10+) and on this one machine I didn't check the RRD data immediately after the upgrade. The upgrade was done around Jan 1, 2014 and now there is no data for any interfaces except for the 4-year graph which has data from about May 2011 - Oct 2012. In addition, no data since the upgrade has been collected or at least it is not showing up. I've checked other upgraded boxes and they don't have this problem.

    I know the RRD was working before this upgrade as I reviewed it at least every few weeks.

    I found http://lists.pfsense.org/pipermail/list/2013-October/005041.html which recommends a few commands:

    include("shaper.inc");
    include("upgrade_config.inc");
    include("rrd.inc");
    upgrade_080_to_081();
    

    I've run these and they result in```
    Feb 3 07:53:46 php: /exec.php: Creating rrd update script

    
    When I first tried to check the RRD page I got a series of errors in the logs like this:
    

    php: /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: No DS called 'inpass6' in '/var/db/rrd/lan-traffic.rrd'/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/lan-traffic.rrd-week.png --start 1390837635 --end 1391442435 --step 3600 --vertical-label "bits/sec" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "hostname - LAN :: Traffic - 1 week - 1 hour average" --height 200 --width 620 DEF:lan-in_bytes_pass=/var/db/rrd/lan-traffic.rrd:inpass:AVERAGE:step=3600 DEF:lan-out_bytes_pass=/var/db/rrd/lan-traffic.rrd:outpass:AVERAGE:step=3600 DEF:lan-in_bytes_block=/var/db/rrd/lan-traffic.rrd:inblock:AVERAGE:step=3600 DEF:lan-out_bytes_block=/var/db/rrd/lan-traffic.rrd:outblock:AVERAGE:step=3600 DEF:lan-in6_bytes_pass=/var/db/rrd/lan-traffic.rrd:inpass6:AVERAGE:step=3600 DEF:lan-out6_bytes_pass=/var/db/rrd/lan-traffic.rrd:outpass6:AVERAGE:step=3600 DEF:lan-in6_bytes_block=/var/db/rrd/lan-traffic.rrd:inblock6:AVERAGE:step=3600 DEF:lan-out6_bytes_block

    
    I also found https://forum.pfsense.org/index.php?topic=66728.0 which references a different GW name but I don't see mine changing and I have looked at all available graphs on the RRD page and each has this problem.
    
    Does anyone have any other suggestions or places I can look to see what's going on?

  • Rebel Alliance Developer Netgate

    That message indicates that your RRD graph files were not updated for 2.1.

    You can wipe the RRD data entirely, or maybe try restoring a 2.0.3 config to 2.1.1 if you have a config with RRD data inside from before the first upgrade attempt.



  • Hi Jim,

    I'd really like to keep the historical data as I have about 3 or 4 years on it.

    I do have a 2.0.3 backup with RRD data from before the upgrade. Since I've made other config changes since 2.1 can I just do this?

    • backup from 2.1 with RRD

    • paste in the 2.0.3 RRD data

    • restore the config to 2.1


  • Rebel Alliance Developer Netgate

    No. The RRD upgrade is triggered by restoring a 2.0.3 config to 2.1. If you put the 2.0.3 data in a 2.1 config it will think it's OK as-is and won't touch it.



  • Okay, still haven't tried this but I have a little window to try tonight. I'm now thinking to:

    • Backup 2.1 without RRD

    • Restore 2.0.3 config(triggering the RRD update) with RRD and verify the RRD is restored properly (which will break a few things until the next step)

    • Restore the 2.1 backup without RRD

    If that doesn't work I'll revert to my snapshot before the 2.1 upgrade and then upgrade again and hopefully the RRD will successfully update this time. After that happens I can restore the backup of 2.1 that I took before rolling back to the snapshot.



  • FWIW, I ran into this same issue on a couple firewalls that were upgraded from 2.0.3 to 2.1.3. But not all of them for some weird reason.

    Seems to affect most traffic/packets graphs on the affected systems.

    Will try deleting the .rrd files I guess. There isn't a way to manually upgrade the affected .rrd files?


Log in to reply