Cannot use xml file from 1.2.x to 2.1



  • Hello,
    my "old" pfsense 1.2.x just died and i'm trying to upgrade to 2.1, i have a backup that cannot be used as it says "The configuration could not be restored" (nothing else).

    i am not familiar with .xml so i am just attaching the 2 backups i have:
    1- as .txt because .xml is not authorized
    2- i have 2 backups (1 with packages and 1 without - i think)

    if anyone can have a look at it it would be great.
    Thanks,
    S.
    pfsense_xml.txt
    pfsense_xml1.txt



  • After removing all the {rtf} stuff at beginning and end, and removing the "/" at the end of every line, the configs parse fine. Hopefully the attached files will load OK onto a 2.n.n system.
    I don't know what you (or your system/s) did to turn these into "rtf".

    config_lfph_big.txt
    config_lfph_small.txt



  • Hello and thanks a lot, it seems the 2.x is willing to accept the xml file but i get this error with both files:
    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 64 bytes) in /etc/inc/pfsense-utils.inc on line 2207

    S.



  • I tried restoring the small one to a test system. After some time I get:

    Warning: rename(/cf/conf/rrd.tgz,/cf/conf/backup): Is a directory in /etc/inc/upgrade_config.inc on line 1994 
    

    The test system was already running 2.1.1-prerelease and the restore seems to be trying to do conversion stuff to the RRD data already on the test system.
    But it does suck in the config OK. When I reboot, of course, I get a bunch of interface mismatch messages… since my test system hardware is nowhere near the same as yours.
    The line 2207 is when it is sucking the config into the parser - so somehow you are feeding it something that sends it into a loop reading in data and eventually explodes when it runs out of memory to store what it thinks is the config text.


  • Rebel Alliance

    Have you tried restoring your config.xl in a 1.2.x install, then install the "Pre-2.0 Upgrade Check package " and once you have a "clean" config. restore it to a 2.1 install….



  • Hi,
    so here where I am:

    I can restore the interfaces but then it tells me that i need to reboot the firewall - this is where i'm loosing connection to the web gui; tried to reboot directly on the machine but then i have to start all over again (i also tried to change to 192.168.1.1 in xml file as it on default on the LAN card-mine is 192.168.125.1 but it doesn't help)

    I could try to install the config on 1.2.3 and then upgrade,  i have a HP 64 proc, 1 gB ram - http://files.nyi.pfsense.org/mirror/downloads/old/ i tried that one: pfSense-1.2.3-RELEASE-LiveCD-Installer.iso.gz  but it doesn't install, just rebooting ad lib, do you know which one i should use?

    Anyway, thanx a lot again - free beers anytime you're in Copehagen-Denmark

    S.


  • Netgate Administrator

    You have the LAN interface set to use 192.168.125.1/24 but you have DHCP and outbound NAT rules referring to 10.10.10.X/24 for LAN. Might be causing some issues, I run into problems assigning DHCP ranges that no longer exist before.

    Steve



  • Hello to all of you,
    I finally made it by reloading a 1.2.3 version, for info:
    1: i used a Dell optiplex but i needed to put 2 "old" network-cards, the 1.2.3 cannot recognize the on-board one.
    2: i had no problem with the LAN interface IP and the DHCP rule having a different range of IP  addresses , still I dont why it's that way; i didn't set up that config, just took over (i dont think thats the right way to do it but its working).

    I would like to thank everyone here: both reading and answering or helping others with issues.

    Anyone in Denmark, beers are waiting!
    s.