Modding firebox x750e to pfsense 2.1

  • Dear all,

    We tried to modding the firebox x750e to pfsense. And after a recent upgrade, some error prompted:

    "Fatal Trap 6: arithmetic trap while it kernel mode" (Please refer to the screenshot).

    and it will auto reboot and it seems without issues.

    The packages we installed is only LCDproc and LCDproc-devel, which I don't think it related to the issues.

    The issues will happen while I reboot the firewall thru command line everytime. I am not sure if it is related to the recent upgrade to pfsense 2.1, or any hardware failure. Can anyone give me some pointers?


  • Netgate Administrator

    So this happens at every boot? Has it ever successfully booted 2.1?

    What command are you using to reboot?


  • Dear Steve,

    Either from web configuration UI or pfsense menu can also repo.

  • Netgate Administrator

    Right, so it does it every time? What about a cold boot?


  • It only happens while we tried to restart it, as I mentioned on first thread. Thanks.

  • Looked around for that error and found something:

    Yeah the post is very old but may shed some light on the subject.

  • Dear Darkk,

    Thanks for your reply.

    I also suspect it maybe a BSD bug, not related to pfsense itself, just because pfsense is designed based on BSD. But according to the thread, it doesn't provide any resolution.

    Are there any clues that I missed?

  • Netgate Administrator

    Yes I looked at that, one of the few Google hits on that error string, but it doesn't seem to be related as far as I can tell. It also wouldn't explain why this only happens after a warm boot.  :-
    After a warm boot some devices are not cleared down to their initial values. The various configurations registers in the NICs, the SuperIO chip and the ICH are set by the bios and remain that way until powered down. Are you running the modified NIC drivers? They set registers on the NICs that aren't set by the BIOS. I'm running those though and don't see this issue.
    Do you have any other unusual config or hardware?

    I'm just guessing here really, I've never seen that error on any of my boxes.


  • Netgate Administrator

    If you look at a boot log from a similar box, for example this one from 2.1 on an X1250e:,71177.msg388754.html#msg388754

    You can see that the next item to be initialised is the cryptosoft device. Something that may well cause an arithmetic error perhaps? Though because it's virtual it can't hang over from a previous config. Do you have any crypto hardware?
    Then it's ACPI stuff and that could cause this. Do you have ACPI enabled in the BIOS?


Log in to reply