DynDNS issue



  • So setup my DynDNS provider for RDP purposes.  I can at present:

    1. RDP from outside of my network (e.g. over LTE) and access my desktop using the DynDNS address
    2. RDP from inside my network (over WiFi) using the local IP address (e.g. 192.168.1.XXX)

    What I cannot do is RDP from inside my network (over WiFi) using the DynDNS address.  Why is that? What should I be doing to be able to use the xxxxxx.dyndng.org address internally over WiFi?



  • You need to:
    a) Turn on NAT reflection; or
    b) Add a host override in DNS Forwarder to define your DynDNS name to be the local IP address, then when you lookup the name from the local LAN you get the real private IP of the client, when you lookup the name out on the internet you get the public IP.

    Personally I go with option (b) - for me it is easy to understand and there is no tricky software happening.



  • Phil,

    Wanted to thank you for your help.  Will be donating to INF.  Sorry for delay in responding as I was out of town and wasn't able to apply solution until now.



  • Follow up question: I also want to run on the same network a Calibre server.  Port forwarding works so I can access the server from outside the network using DynDNS address and local port.

    Should I want to do the same thing to access the book server locally on a client like MoonReader for Android, do I need a second DynDNS address?  If not, how can I accomplish same (applying option b) with a second server (obviously using a different port)? Much appreciated.



  • @phil.davis:

    You need to:
    a) Turn on NAT reflection; or
    b) Add a host override in DNS Forwarder to define your DynDNS name to be the local IP address, then when you lookup the name from the local LAN you get the real private IP of the client, when you lookup the name out on the internet you get the public IP.

    I agree with what phil.davis has said.

    Or the third option is you stop doing silly naked RDP over the internet and set up OpenVPN.  That way your RDP port is not hanging itself bare-bum on the internet for all of china to find.



  • @phreshjive:

    Follow up question: I also want to run on the same network a Calibre server.  Port forwarding works so I can access the server from outside the network using DynDNS address and local port.

    Should I want to do the same thing to access the book server locally on a client like MoonReader for Android, do I need a second DynDNS address?  If not, how can I accomplish same (applying option b) with a second server (obviously using a different port)? Much appreciated.

    You just use the same dynamic dns but add a port on the end no need for a second b entry. mydynamicdns.com:port if you want to access a different port then the application wishes to by default usually.



  • Ended up disabling RDP after a few colleagues took a dump on me over using it.  Now using TeamViewer.  Thank you for help.



  • @phreshjive:

    Ended up disabling RDP after a few colleagues took a dump on me over using it.  Now using TeamViewer.  Thank you for help.

    Whats wrong with RDP?