Fatal traps 10 and 12



  • Tired installing pfsense tonight on my Gateway 920 server and ran into trouble.
    Its a p4 2.6, pc2100 2 x 256 ram ecc reg, 60 gig HD.  I've disabled serial, floppy, parallel and the onboard nic as of now.  No addition network card are currently installed.

    I've tried the latest snapshot and and 1.2RC3 and both gave me a fatal trap 10: trace trap while in vm86 mode, 1.0.1 gives me a fatal trap 12, supervisor write, page not present.

    any help would be appreciated.



  • When do you get these errors, during or after install?

    Did this work with another OS before you tried pfSense?



  • the fatal traps are occurring as soon as i pressed 1 or enter to do the default boot of freebsd, also tried safemode.

    I've installed ubuntu server, debian etch and untangle without any problems.



  • What about FreeBSD 6.2?  What if you disable ACPI?



  • downloaded freebsd 6.2 and i get the same fatal trap 10 error and disabling acpi doesn't help.



  • You're probably out of luck then.  I'd suggest looking for BIOS upgrades and trying disabling USB in the BIOS.



  • I get same errors and also other OSes worked. At the and i tried to take one memory module out of the machine and replaced bad ram and box works now with flying colors. Maybe i should also note that memtest didn't detect any errors on bad ram module.



  • Try a recent ISO (snapshots.pfsense.com/FreeBSD6/RELENG_1_2/iso.  We commited a kernel change that helped with these fatal traps on certain hardware.



  • Tried and doesn't work. I get: vm_fault c2061000. I get this error almost after detecting cdrom. Last message befor error starts with GEOM_Label (or something similar) iso9960/pfSense



  • Yep, it does not like your CDROM drive for some reason.



  • I also tired with antoher CD drive and it doesnt worked until i replaced RAM. As i mention before…after i replace ram it worked.


Log in to reply