Squid com Cache Dinamico youtube



  • boa noite.
    Galera talvez alguem possa ter passado por algo assim ou alguma sugestão.
    Já tem algums dias que estou na luta para fazer o cache dinamico com o youtube funcionar.
    Tenho simulando tanto em pfsense 2.1.1 squid3-dev transparente como pfsense 2.1 com squid3-dev transparente como tambem pfsense 2.03 com proxy autenticado.
    O problema que ambos os casos quando habilito o cache do youtube e analiso os logs o squid para de gerar TCP_HIT.
    Já procurei varios documentos e todos ate agora não resolveram.
    Vi que o Jack postou que o squid3 para cache dinâmico é necessário ter no mínimo 4 GB de ram.
    Alguém tem ideia de como fazer este cache funcionar de maneira efetiva com youtube?
    Desde já agradeço



  • Eu novamente.
    Pessoal talvez alguém tenha alguma ideia.
    Já estou a dias ralando com este cache do youtube no squid3 e squid3-dev em modo transparente.
    Habilito o cache dinamico e youtube simplesmente ele faz o cache do conteudo do youtube em seguida não faz mais.
    Interessante que tenho o mesmo senario com squid autenticado e funciona bem.
    Alguém tiver alguma ideia de como resolver isso.
    Será e algo no proxy em modo transparente?



  • Bom dia.
    Galera pelos meus testes consegui resolver o problema do cache do youtube do squid3 de muitos dias apanhando.
    Vamos la.
    Nas versões do pfsense 2.03, pfsense 2.1 e pfsense 2.1.1 com o squid3 na aba local cache deixar somente o chek box Cache Dynamic Content habilitado.
    Não utilize Refresh Patterns do youtube em nem uma destas versões do pfsense acima.
    Este Refresh Patterns tem veses que funciona e outra veses não, ou então para de fazer cache do youtube do nada.
    Na aba geral do squid3 no campo Custom Options colocar estas linha abaixo.

    acl googlevideo dstdomain .googlevideo.com
    cache allow googlevideo
    acl youtube dstdomain .youtube.com
    cache allow youtube
    acl QUERY urlpath_regex cgi-bin ?
    cache deny QUERY

    Obs.
    Caso for utilizar LoadBalance no pfsense 2.1.1 e modo transparente você não poderá utilizar o parâmetro tcp_outgoing_address 127.0.0.1 no campo Integrations na aba geral do squid3.
    Este parâmetro não deixa o squid3 fazer cache do youtube.
    Já em pfsense 2.03 em modo autenticado e com failover pode se utilizar o parâmetro tcp_outgoing_address 127.0.0.1 no campo Integratios e colocar os parametros de cache do youtube no campo Custom Options.
    No pfsense 2.1 só informar estes parâmetros no campo custom Options, nesta versão não testei com load balance.
    Conforme o Jack informou em um post aqui no forum o squid para efetuar cache do squid deverá ter 4 GB de ram ou superior para que faça cache do youtube de forma eficiente.
    Outra questão importante que utilizando o squid3 em modo transparente ou autenticado tando no pfsense 2.03 como no pfsense 2.1 caso precisa parar o squid3 e inicializa-lo você tera que após a inicialização ira na aba cache do squid e salvar as configurações do cache novamente.
    Não entendi ainda o motivo mas nos meus testes sempre que eu parava o squid3 e inicializava o squid3 parava de fazer cache do youtube mas os demais sites continuava fazendo cache normalmente.
    Já no squid3-dev no pfsense 2.1.1 ainda continua o mistério do cache do youtube não fazer cache.



  • Uma observação.
    Utilizando o pfsense 2.1.1 com o squid3-dev em modo transparente o cache do youtube encontra instável.
    Tentei utilizando as configurações da GUI do squid3-dev porem sem sucesso.
    Quando consegui foi utilizando estas configurações que utilizei no squid3 porem elas param de fazer cache no proxy do squid ou param de fazer cache de sites como uol que sem o parâmetro de cache do youtube faz cache normalmente.