Usando squid+squidGuard as páginas dão time out e só funcionam ao recarregar



  • Nos últimos dias a navegação está dando problemas. Quando alguém acessa um site ele fica carregando até dar tempo expirado, aí basta atualizar a página para ela carregar automaticamente.
    Já usei com e sem cache ativados, já reiniciei todos os serviços e nada…

    Minha configuração é pfSense2.1+squid+squidGuard+autenticação integrada ao AD. Em horário de pico o número máximo de usuários pode chegar a 75.

    Não tenho nenhuma regra no firewall (só as padrões), e no squidguard somente filtro sites indesejáveis.
    No custom options do squid tenho:

    acl windowsupdate dstdomain windowsupdate.microsoft.com;
    acl windowsupdate dstdomain .update.microsoft.com;
    acl windowsupdate dstdomain download.windowsupdate.com;
    acl windowsupdate dstdomain redir.metaservices.microsoft.com;
    acl windowsupdate dstdomain images.metaservices.microsoft.com;
    acl windowsupdate dstdomain c.microsoft.com;
    acl windowsupdate dstdomain www.download.windowsupdate.com;
    acl windowsupdate dstdomain wustat.windows.com;
    acl windowsupdate dstdomain crl.microsoft.com;
    acl windowsupdate dstdomain sls.microsoft.com;
    acl windowsupdate dstdomain productactivation.one.microsoft.com;
    acl windowsupdate dstdomain ntservicepack.microsoft.com;
    acl CONNECT method CONNECT;
    acl wuCONNECT dstdomain www.update.microsoft.com;
    acl wuCONNECT dstdomain sls.microsoft.com;
    http_access allow CONNECT wuCONNECT localnet;
    http_access allow windowsupdate localnet;
    acl java_app browser Java/1.4 Java/1.5 Java/1.6 Java/1.7;
    http_access allow java_app;
    acl java_vm browser regexp -i Java;
    acl java urlpath_regex -i \.class$ \.jar; 
    http_access allow java;http_access allow java_vm;
    acl_uses_indirect_client on;
    follow_x_forwarded_for allow localhost;
    auth_param ntlm program /usr/local/bin/ntlm_auth --use-cached-creds --helper-protocol=squid-2.5-ntlmssp;
    auth_param ntlm children 10;
    auth_param ntlm keep_alive on;
    acl password proxy_auth REQUIRED;
    http_access allow password;
    redirect_program /usr/pbi/squidguard-i386/bin/squidGuard -c /usr/pbi/squidguard-i386/etc/squidGuard/squidGuard.conf;
    redirector_bypass off;
    url_rewrite_children 5
    

    Alguém tem alguma dica?
    Agradeço desde já



  • @zilmar:

    Nos últimos dias a navegação está dando problemas. Quando alguém acessa um site ele fica carregando até dar tempo expirado, aí basta atualizar a página para ela carregar automaticamente.
    Já usei com e sem cache ativados, já reiniciei todos os serviços e nada…

    Minha configuração é pfSense2.1+squid+squidGuard+autenticação integrada ao AD. Em horário de pico o número máximo de usuários pode chegar a 75.

    Não tenho nenhuma regra no firewall (só as padrões), e no squidguard somente filtro sites indesejáveis.
    No custom options do squid tenho:

    acl windowsupdate dstdomain windowsupdate.microsoft.com;
    acl windowsupdate dstdomain .update.microsoft.com;
    acl windowsupdate dstdomain download.windowsupdate.com;
    acl windowsupdate dstdomain redir.metaservices.microsoft.com;
    acl windowsupdate dstdomain images.metaservices.microsoft.com;
    acl windowsupdate dstdomain c.microsoft.com;
    acl windowsupdate dstdomain www.download.windowsupdate.com;
    acl windowsupdate dstdomain wustat.windows.com;
    acl windowsupdate dstdomain crl.microsoft.com;
    acl windowsupdate dstdomain sls.microsoft.com;
    acl windowsupdate dstdomain productactivation.one.microsoft.com;
    acl windowsupdate dstdomain ntservicepack.microsoft.com;
    acl CONNECT method CONNECT;
    acl wuCONNECT dstdomain www.update.microsoft.com;
    acl wuCONNECT dstdomain sls.microsoft.com;
    http_access allow CONNECT wuCONNECT localnet;
    http_access allow windowsupdate localnet;
    acl java_app browser Java/1.4 Java/1.5 Java/1.6 Java/1.7;
    http_access allow java_app;
    acl java_vm browser regexp -i Java;
    acl java urlpath_regex -i \.class$ \.jar; 
    http_access allow java;http_access allow java_vm;
    acl_uses_indirect_client on;
    follow_x_forwarded_for allow localhost;
    auth_param ntlm program /usr/local/bin/ntlm_auth --use-cached-creds --helper-protocol=squid-2.5-ntlmssp;
    auth_param ntlm children 10;
    auth_param ntlm keep_alive on;
    acl password proxy_auth REQUIRED;
    http_access allow password;
    redirect_program /usr/pbi/squidguard-i386/bin/squidGuard -c /usr/pbi/squidguard-i386/etc/squidGuard/squidGuard.conf;
    redirector_bypass off;
    url_rewrite_children 5
    

    Alguém tem alguma dica?
    Agradeço desde já

    Zilmar você utiliza de que forma a autenticação no ad…. e com samba ntlm ou identd?



  • @calebe:

    Zilmar você utiliza de que forma a autenticação no ad…. e com samba ntlm ou identd?

    Com o Samba, fiz igual esse tópico: https://forum.pfsense.org/index.php/topic,66674.msg364055.html#msg364055