Vlan Netgear GS108T



  • I have servers in my basement (wired to a switch) which is then wired to a router, then wired to eth0 (LAN) on Pfsense.
    I want to have the DNS server (green- in diagram) ONLY able to access the internet, and NOT the other computers (blue- in diagram).. Where as the other computers can access themselves like normal. I've read about 20 different tutorials, posts, and the documentation and still can't get pfsense to give the server an IP (I don't know if it's my configuration or if maybe the NICs are stripping the vlan identifier).

    I only have one cable running to the basement, and would rather not run another - however if that's required I have another free nic on pfsense so might as well just use that instead of setting up a vlan.

    In the pictures, that's how everyone else configured it, and when I configure it that way the dns server will not get an IP (DHCP unreachable), and can not ping pfsense. The only way for it to work is have port 8 set as U in VLAN 1 membership, and port 8 (g8) in PVID configuration set to PVID 1.. I've tried just about every combination I can think of but still can't get it.

    Here's the better looking version of the images (had to compress big time):
    Network Diagram
    Pfsense_Interfaces
    Netgear_VLanConfig
    Netgear_VlanMembership
    Netgear_PVIDConfig
    Pfsense_VLAN10
    Pfsense_DHCPVlan

    Thanks!















  • Netgate Administrator

    Have you set firewall rules on VLAN10? DHCP should still work however.

    Try running a packet capture on em0 to see if any VLAN10 tagged dhcp requests or offers are there.

    How does the wireless router handle VLANs? Is it trunked through or are you just hopnig it won't strip the tags or dumpt the packets?

    Steve