Squid3 w/ SquidGuard3 Transparent Mode



  • Hello all,

    Trying to use SquidGuard3 with my Squid Install. I've set everything up and it seems to work great if I point my browser to use the proxy manually. If I remove the settings from my browser and enable transparent mode (or use redirection firewall rule) I am not able to hit any HTTP websites.

    
    The following error was encountered while trying to retrieve the URL: /
    
        Invalid URL
    
    Some aspect of the requested URL is incorrect.
    
    Some possible problems are:
    
        Missing or incorrect access protocol (should be "http://" or similar)
    
        Missing hostname
    
        Illegal double-escape in the URL-Path
    
        Illegal character in hostname; underscores are not allowed.
    
    

    Not really sure what to do. I used to use Dansguardian and it worked fine except it stopped working after I upgraded PFsense to 2.1.

    Any thoughts would be great!

    Thanks



  • What is logged in access.log and squidGuard.log when you make the attempt with transparent enabled?



  • @loupalladino:

    What is logged in access.log and squidGuard.log when you make the attempt with transparent enabled?

    Hi loupalladino,

    Thanks for the response. Sorry for the delay. I tried checking the logs under:

    /var/squid/logs
    /var/squidGuard/log

    but I do not see any errors in either. Under access.log I do see the requests I've made.

    Also note I tried removing all squid. Even when under pkg_delete and removed anything left behind. Re installed just Squid3 and turned on transparent mode and the problem still exists…

    Thoughts?

    Thanks


Log in to reply