Problema acessar apache hospedado internamente.



  • Bom dia!

    Tenho um servidor apache na rede que disponibiliza acesso a algumas informações do banco de dados para a WEB.
    No site da empresa tem um link que se conecta ao ip local….onde esta este apache...

    Externamente funciona normal....o problema é quando o pessoal da rede interna clica neste link....simplesmente não resolve...

    se eu pego esta URL do site...colo no navegado ....substitui o ip 201.xxx.xxx.xxx pelo ip interno do apache 10.0.0.X....funciona....

    ou seja ....meu firewall esta restringindo acesso da rede interna ao ip externo...

    tentei fazer alguns NAT...mas não resolveu...

    alguém tem ideia de como resolvo isso?....



  • tive o mesmo problema aqui, porém resolvi de uma forma que pode-se dizer "gambiarra"

    os meus webservers no qual tem endereço dns eu simplesmente fiz um overrride no dns forwader apontando o endereço dele para o ip local.

    agora, eu também tenho alguns serviços que acessam diretamente pelo endereço de IP(acho que é seu caso), nesse caso eu precisei fazer um index.php que checa o ip da pessoa, se for local redireciona para o ip local do server, se não redireciona para o ip publico.



  • @yurimpn:

    tive o mesmo problema aqui, porém resolvi de uma forma que pode-se dizer "gambiarra"

    os meus webservers no qual tem endereço dns eu simplesmente fiz um overrride no dns forwader apontando o endereço dele para o ip local.

    agora, eu também tenho alguns serviços que acessam diretamente pelo endereço de IP(acho que é seu caso), nesse caso eu precisei fazer um index.php que checa o ip da pessoa, se for local redireciona para o ip local do server, se não redireciona para o ip publico.

    Entendi…..mas dessa forma de criação de um novo index não vai rolar....

    O pessoal que cuida do sistema e do webserver não vão se envolver....

    Como funcionava antes no iptables....eles querem que funcione sem mexer na parte deles....

    Imagino ser alguma regra de NAT..... mas não manjo muito....e estou meio perdido para resolver isso...



  • Resolvido…

    Em

    System: Advanced: Firewall and NAT

    habilitei

    Enable automatic outbound NAT for Reflection

    funcionou certinho…

    yurimpn....valew pela ajuda!



  • @edge540:

    Resolvido…

    Em

    System: Advanced: Firewall and NAT

    habilitei

    Enable automatic outbound NAT for Reflection

    funcionou certinho…

    yurimpn....valew pela ajuda!

    Bom dia
    Estou com a mesma situação, crei uma regra NAT e marquei as opções de  fora ta tranquilo mas internamente nada ainda. Vc fez mais alguma coisa?