Assign roles to users



  • Hi,

    I'd need to allow some people to set up the mac passwthrough, while not allowing them to touch the rest of the configuration.

    Is there any way to do that?

    Thanks



  • I'm having same problem.
    Here are the privilleges I have setted:

    WebCfg - Dashboard (all): so login works, otherwise user can't login
        WebCfg - Services: Captive portal: Allowed IPs page: Its dupplicated, so I think one must be "Pass-through MAC"'s tab
        WebCfg - Services: Captive portal: Edit Allowed IPs page
        WebCfg - Services: Captive portal page: so captive portal options appears on services' menu

    But still not working. :o


  • Netgate Administrator

    Create a new user group. Assign priviliges to that group to control which webgui pages they can access. Add new users that are in that group.
    https://doc.pfsense.org/index.php/Group_Manager

    At least that's how it's supposed to work. What's 'not working' for you Eduardo?

    Steve



  • @stephenw10:

    At least that's how it's supposed to work. What's 'not working' for you Eduardo?
    Steve

    When I login with permissions below:

    • WebCfg - Dashboard (all): so login works, otherwise user can't login

    • WebCfg - Services: Captive portal: Allowed IPs page: Its dupplicated, so I think one must be "Pass-through MAC"'s tab

    • WebCfg - Services: Captive portal: Edit Allowed IPs page

    • WebCfg - Services: Captive portal page: so captive portal options appears on services' menu

    On Services menu appears only 'Captive Portal', as it should. But when I click on 'Captive Portal' nothing happens.
    It's missing permission to 'services_captiveportal_zones.php'. If I access 'https://10.1.1.1/services_captiveportal_ip.php?zone=sala_pesquisa', test user can edit IP Address.
    How can I add a custom permission 'WebCfg - Services: Captive portal Zones (Dashboard/readonly)'?
    'WebCfg - Services: Captive portal: Allowed IPs page' and 'WebCfg - Services: Captive portal: Edit Allowed IPs page' are dupplicated here. And I don't have 'WebCfg - Services: Captive portal: Edit Pass-through MAC', nor 'WebCfg - Services: Captive portal: Pass-through MAC' permission on 'Privileges'.