Unable to Use Dansguard



  • Hello Experts,

    I am struggling trying to enable Dansguard, this will be running in Transparent-mode.

    Here is what I have done so far:

    1. Download and install Squid Caching Service
    2. Download and Install Dansguard (Enable it to listen on port 8080 for the LAN IP address or loopback 127.0.0.1)
    3. Configure a Port-Forward rule as follows
      Source any
      source port any
      destination any
      Destination port HTTP to HTTP
      Redirect IP (LAN) of my Pfsense box
      Redirect port 8080

    As soon as I enable the rule every HTTP access goes down, I lost HTTP access to the internet. I got to disable the Redirection rule (NAT Statement) in order to get it back again.

    What am I missing?

    Services are up and running
    proxy    squid      15922 41 tcp4  x.x.x.x:3128    :
    proxy    squid      15922 42 tcp4  127.0.0.1:3128        :
    clamav  dansguardi 34333 8  tcp4  x.x.x.x:8080    :

    Any help will be highly appreciated it.



  • Test this in a logical, step-by-step fashion so that you can tell what is broken before adding the redirect rule…

    1.) Validate that Squid and Dans are both running... If so...
    2.) Try connecting the browser (via explicit proxy settings) to squid and make sure you can get out... If so...
    3.) Try connecting the browser (via explicit proxy settings) to dans and make sure you can get out... If so...
    4.) Add the redirect rule and delete your browser proxy settings.