DHCP not working with 1 laptop



  • Hello Pfsense community

    I'm here to tell you about a little problem related to DHCP, in my network;

    Untill today, I never have had one problem in pfsense; everything works really fine; I have only one Firewall/Gateway/DHCP server, that is Pfense. I have used dhcp with one IP range, and have static mapping (MAC) with other range, in order that they never conflict; there are sufficient IPs for everybody in the network;  everything is working fine, really no problem; well, this days, someone asked me why network wasn't working; I said it was, and then looked at what was hapenning: a laptop could not get an IP address; I tested everything: manual config, changed cable and wall jack, booted one livecd linux, but in any case, I get communication from the laptop and my pfsense; it seems it cannot see the laptop; no log activity, showing the laptop asking for an IP, no communication when I configure the network card manually (pinging the firewall do not work), I really do not know what to do; the laptop is new and network connection works fine at home. This week, I was out, but knew that it happened again with another laptop, the same way…

    Does someone has experienced something like that?? what else can I test when this notebook come back??

    Even using static mapping, I am not using "Deny unknown clients", as someone may think...

    Thanks in advance

    Saulo



  • anyone???  ??? ???



  • You need to provide a "bit" more information.
    Like how your network is setup. (a diagram?)



  • Packet captures from an affected laptop would probably be helpful.



  • Also - What OS is the laptop running???

    If Vista make sure the firewall is not interfering!

    (gotta love microsloft)

    gm…



  • my network is a simple one, very simple; laptop is using windows xp, but I have loaded a linux livecd, but even with linux, and using command line: dhclient eth0, I could not get an IP ???

    I do not know what to do anymore…



  • We are experiencing the exact same thing. about 20 machines on the network get ips no problem, but one laptop that an engineer uses does not get a dhcp lease, we have tried static reservation, but still no go, infact we can not even see any message in the dhcp log relating to this laptop at all. If we statically assign on the laptop and don't use dhcp all works fine. This Laptop is running Linux Ubuntu 7.10 and works fine on other client networks with dhcp, just seems to be non functional with PFsense. All our sites are using PFsense 1.2 final.

    Any ideas what this could be, as its starting to be a pain in the butt for us.?



  • Try a different linux kernel version.



  • in my case I have tried windows xp (the original host system) and linux (ubuntu, I think) both dynamic and static configuration; it didn't worked; no related messages in pfsense dhcp logs; tryied different ethernet cables… very very strange...



  • Could the NIC be broken?



  • I'm afraid not just because the notebook owner said that at home he uses his adsl modem via ethernet adapter; he said that at his or his girlfriend home the network adapter works fine; I would say the same if he didnt said that for me, just because I did a lot of tests, with more than one operational system (I did with linux because I trust in its results, cant say the same about win) and could not work.


Log in to reply