Configuring for Vonage



  • I hope this is the right forum section.  Seems like it's a combination of firewalling and NAT that I need.

    One of the guys in my office has a Vonage phone that he wants to use.  He has it hooked up and it works "sometimes," but sometimes he'll make or receive a call and get no audio.

    I've seen some discussion of Vonage here, but I haven't been able to piece together everything that I need to do in order to make it work.

    As it stands, the phone adapter is hooked to the network with a static IP address of 192.168.1.21.  I have a multi-WAN setup, and I've created a firewall rule on the LAN side that says all traffic from 192.168.1.21 should be routed to one of the three static WAN addresses.  But I don't know where to go from there.

    Vonage help says the following:

    Ports used by Vonage Adapters
    The following ports are needed for OUTGOING internet communications from the Vonage device to the Vonage servers:
    DNS: Port 53 UDP
    TFTP: Port 21, 69, 2400 UDP
    HTTP: Port 80 UDP
    NTP: Port 123 UDP
    SIP: Port 5061 UDP (used for older Vonage devices provisioned before 2005)

    The following ports are needed for INCOMING and OUTGOING internet communications from and to Vonage devices and servers:
    RTP (Voice) Traffic: Ports 10000-20000 UDP

    Do I have to set up individual routing or firewall rules for each of those ports/ranges?

    Anybody have quick and easy instructions that a relative newbie can follow to get this Vonage phone running?

    Thanks for the help.

    Jim



  • Got this same problem and im still figuring it out, so far im trying 1:1 NAT well see how that goes.



  • I have no issues, from behind pfsense.  I have made no special provisions.  I just have the bandwith tuning settings settings.



  • Here is what I am doing and it works!  All parameters are set and performed on the LAN (Firewall: Rules) for ports 10000:20000, 514, 2400 and 69.  All ports are UDP!

    So it should look something link this:

    Proto/Source/Port/Destination/Port/Gateway/Schedule or
    UDP/192.168.1.21//10000:20000//*
    UDP/192.168.1.21//514//*
    UDP/192.168.1.21//2400//*
    UDP/192.168.1.21//69//*

    (Later, you could groups all these ports via Aliases)



  • @fastcon68:

    I have no issues, from behind pfsense.  I have made no special provisions.  I just have the bandwith tuning settings settings.

    Sorry for late post…but I also have vonage, with no special settings, I didn't even touch the bandwidth tuning.  It just works with no problems.  My setup is Cable modem ---> pfSense ---> Linksys Gigabit Switch -----> all devices, including vonage (no pc plugged to their pc port, just phone)


Log in to reply