DHCP bug/issue.



  • I ran into a very strange problem this weekend. I use dhcp to configure computers attached to the lan of my pfSense box, the funny thing was that  out of the 7 computers on the lan there was 1 that had 3 lease from the address poll of 192.168.1.10-16 and 2 computers that couldn't get a lease as all were being used up. I checked around and came across the faq that describes this as a bug http://faq.pfsense.org/index.php?sid=28703&lang=en&action=artikel&cat=1&id=137&artlang=en.

    I read the list but it seemed like it was a problem affecting load balanced dhcp servers. non the less this seem to be the same problem. I did some  reading on dhcpd and found that the option 'deny duplicates' should ensure that each ethernet mac address can only be assigned one lease from the address pool. I made the modification to services.ini to add the option to the dhcpd.conf file generated. So far so good but I need a separte box to test this anyhow.

    My question is.. is this really a fix to this problem, the mailing list about this bug/feature didnt make much mention of this option. So im wondering if this will really solve anything?



  • I have commited the change.  In retrospect, this may be one of the reasons why load balancing was eating all the leases.



  • wwwwooo that was quick, was just wondering if this was a possible solution. I still needed more time to test. Anyways Heres a quick finding, 'deny duplicates;' only works with dhcpd.conf host decalrations, this is what pfSense does for static arp entries. It doesnt work otherwise, and was able to duplicate the problem when static arp wasn't used. setting option 'one-lease-per-client true;' works in both  cases.  :)

    I was initially using static arp so deny duplicates worked for me.



  • Okay, I'll commit ne-lease-per-client true; change.

    We are gearing up for beta 2.



  • thing you made a mistake on that.. u need sleep man  :D.

    one-lease-per-client true;



  • Yes, I caught that immediately.


Locked