PPPoE clients connect but no network access :(



  • Hi,

    I have tried this from an out of the box installation and also with a working Captive Portal on pfsense and get the same problem on both systems.

    I set up a PPPoE server to use a /25 (- 128 IP's as when I chose /24 the first IP it gives is a .0 which seems silly, is this a bug?)
    I set up the PPPoE server to use Radius accounting from a different server which works fine.

    My client can connect to the PPPoE server with a WAN router  but not get any network access.

    I have added a pass through rule in the PPPoE part of the firewall

    I followed this very simple tutorial - http://pfsensesetup.com/pfsense-pppoe-server-configuration/

    my network is like this:

    WAN: 10.33.5.3/16 (from DHCP) - Internet gateway server is: 10.33.5.1
    LAN: 10.66.1.254/16

    PPPoE settings:
    Server: 10.66.1.253 /25  <– I can access this IP to configure the server through my PPPoE Client, so at least some of the networking is working!
    Range: 10.66.1.128
    interface: LAN

    I have tried various settings but just can't get any ping from my PPPoE Client router (or PC connected to the client router) to connect to even the gateway PC which is on the WAN side of PPPoE or any internet IP address, let alone DNS etc. I figured this must be a firewaling issue but I will start in this PPPoE category first.

    Thanks for any help!!



  • Perhaps I have fixed my own problem, only now I find that there is no traffic shaping for PPPoE, I will start a new question unless anyone knows a simple answer to "how to traffic shape for PPPoE".

    To answer my question, it seemed that my client PPPoE router could have been at fault, I created a new PPPoE connection from my Ubuntu box bypassing my client router it connected fine, giving me Internet, YAY!!!

    I am keen to connect with other WISP/ISP type people to collaborate on getting the best out of what equipment etc we use, please feel free to PM me and we can start a group lol



  • @timb0:

    Hi,

    I set up a PPPoE server to use a /25 (- 128 IP's as when I chose /24 the first IP it gives is a .0 which seems silly, is this a bug?)

    Happens to me. I have to chose 25 sub



  • Hi at all,

    I've the latest release 2.1.4-RELEASE (amd64) installed on a Ubuntu pc's and I use Virtual Box and it work fine .
    I use pfsense as netbalancer with 2 WAN connection and it work fine .

    But is for few days that I try to configure the pppoe server, but without success.

    With the help of mais_um are able to reach the server by changing to 25 the subnet mask, works for few seconds but disconnects.
    To get a little connection I add manually the outbound NAT rules, but don't resolve this problem.
    here are my configurations…

    Services: PPPoE Server: Edit
    Interface  LAN
    Subnet Mask 25
    No. pppoe user 254
    Server Address 1.1.1.1
    Remote Range  2.2.2.2
    
    
    Firewall: NAT: Outbound
    Interface  Wan1
    Protocol    any
    Source      Network   Address 2.2.2.0/24
    Destination any
    
    Firewall: Rules: pppoe server
    Action      Pass
    Interface pppoe vpn
    protocol any
    source   any
    destination any
    gateway   loadbalcer
    

    What's wrong or missing?

    I hope in a help. Bst Rgrds Christian