Squid3-dev update



  • Does anybody know what this update include as a change?

    Update Available!
    Current: 3.3.10 pkg 2.2.1
    Installed: 3.3.10 pkg 2.2

    Regards,



  • bump



  • This update is for in cooperating clamd and icap antivirus process with squid, require bit of tweaking.

    One issue I find out after reboot , We have to press squid save setting again to work perfectly (may be I am doing something wrong). Otherwise no other changes.



  • @exograpix:

    This update is for in cooperating clamd and icap antivirus process with squid, require bit of tweaking.

    did you get the antivirus working ? i'm getting a "ICAP protocol error, The system returned: [No Error]" when trying to access web pages with the antivirus option enabled

    Any hints on what to "Tweak"

    TIA



  • Install squid-dev, than start squid in transparent mode. restart pfsense (recommended) and than enable antivirus in squid and wait for clamd service to get green. It will take 15-20 minutes to get updated and require refresh on service status page few time after update.

    It will work, there is another issue of non working after reboot .



  • Thanks for the info!



  • quick question.. what is the difference in clamd in dansguardian and the one in this? Is clamd with icap more effective?



  • @asterix:

    quick question.. what is the difference in clamd in dansguardian and the one in this? Is clamd with icap more effective?

    clamav on squid3-dev can check ssl sites if ssl filtering is enabled.



  • I suppose SSL filtering is not available on Squid 3.1.20 pkg 2.0.6. at least I don't see an option anywhere.

    I have a stable UTM working right now… do you recommend moving up to squid-dev or wait till all the kinks are straightened out?



  • @asterix:

    I suppose SSL filtering is not available on Squid 3.1.20 pkg 2.0.6. at least I don't see an option anywhere.

    I have a stable UTM working right now… do you recommend moving up to squid-dev or wait till all the kinks are straightened out?

    squid-dev has squid 3.3.10 stable version but clamav is no working on amd64 for now.

    But on 2.2 squid3 package is squid3-dev as squid 3.1.20 is old and not present on freebsd ports anymore.

    Some forum users reported that squidguard3 is not working with squid3-dev. I did not had time to test it because I do not use squidguard.



  • @marcelloc:

    Some forum users reported that squidguard3 is not working with squid3-dev. I did not had time to test it because I do not use squidguard.

    Working…

    https://forum.pfsense.org/index.php?topic=73640.msg402286#msg402286

    https://forum.pfsense.org/index.php?topic=73740.0 (Spanish Forum)


Log in to reply