Squidguard doesnt' work



  • Hi,
    fresh install of pfsense with packages squid and squidguard. The problem is that squidguard doesnt work. I downloaded blacklists from urlblacklist, squidguard is enabled, blacklist chceckbox also, when I set target category for example porn to deny nothing is blocked. Squid proxy config is as follows:
    proxy interface: lan
    proxy port: 3128
    allow users on interface: checked
    transparent proxy: checked


  • Netgate Administrator

    Are the sites using https? Are the URLs you are testing actually in the blacklist?

    Steve



  • @stephenw10:

    Are the sites using https?

    No.
    @stephenw10:

    Are the URLs you are testing actually in the blacklist?

    Yes.


  • Netgate Administrator

    So nothing is being blocked at all?  Is the proxy even being used? You seem to have both a proxy port and a transparent setting, usually you would only have one or the other.

    Really this question should be in the Packages subforum.

    Steve



  • So nothing is being blocked at all?

    OK, after many hours of clicking - disabling, reloading, changing settings etc. porn blocking is working now, I get this:

    
    Request denied by pfSense proxy: 403 Forbidden
    Reason: Client address: 192.168.1.153
    Client group: default
    Target group: blk_BL_porn
    URL: http://sex.com/
    
    

    I dont know how I did it. BUT nothing more! When I set for example chat category for deny nothing is blocked. I unpacked blacklist.tar.gz archive to check correct blacklisted domains for example skype.com is blacklisted in the chat category and block is NOT WORKING! What is going on?

    Really this question should be in the Packages subforum.

    Oh, sorry.

    Today, when I turned on my hardware it seems that some addresses that are blacklisted are blocked and some not for example plugoo.com is blocked but skype.com and pidgin.im is not. THIS IS SICK!



  • Based on what I have experienced, setting url redirect upon blocked list does not work, user still can access whatever I wanted to blocked. Setting the url redirect to NONE solved my problem, I am still curious as we speak.



  • url redirect to NONE

    What is that?


Log in to reply