Squid and squidguard not working



  • I wasted almost a week for this. You are my last chance before I sent this pfsense toy to trash. Nothing is blocked with squid3 and squidguard3. In the target rule list default access is set to allow, and for example chat and porn for deny. In the squidguard log I have for example:

    http:// www. sex.com /images/background.jpg Request(default/blk_BL_porn/-) - GET REDIRECT

    And the site loads like a charm.

    In my opinion config is correct.

    Squid config:
    http://i62.tinypic.com/2iatslf.jpg
    http://i62.tinypic.com/199fmw.png
    http://i58.tinypic.com/v78f3k.png

    Squidguard config:
    http://i62.tinypic.com/30jnwx2.png
    http://i57.tinypic.com/1h35hi.png
    http://i62.tinypic.com/xmpv85.png



  • Try squidguard with theĀ  Miscellaneous: "clean advertising" option turned off.

    Check this option to display a blank gif image instead of the default block page. With this option the user gets a cleaner webpage.
    

    Have you pressed "apply" on the first page of squidguard after you pressed save at the bottom?
    The int redirect blank option creates a full url with "http://" maybe add that to the "www.google.com" part of your external redirect url.

    Does this also happen when you choose "int blank" instead of "ext url redirect"?

    Maybe it helps others to determine the issue by posting the config log text, you get in the log page of squidguard.



  • Have you pressed "apply" on the first page of squidguard after you pressed save at the bottom?

    Yes, first save then apply.

    "http://" maybe add that to the "www.google.com" part of your external redirect url.

    That works, but not for all pages for example skype.com or pidgin.im loads without a problem, those are blacklisted in the chat category. Is it possible to redirect to custom html page?



  • Hmm, add the pidgin.im and skype.com IP's to the block lists?
    Maybe the webservers of those sites aren't strict on the full domain name, so the squidguard is strict and won't recognize the address exactly.

    
    www.skype.com
    skype.com (assumes "www." and goes to the site)
    whatever.skype.com (assumes "www." and is not recognized by squidguard)
    
    

Log in to reply