PPoE WAN not acquiring IP



  • I have a Routit VDSL uplink with a Draytek Vigor 130 modem, however when I enable PPoE passtrough and set up my WAN interface as PPoE no IP address is acquired
    Interface status:

    WAN1 interface (pppoe0)
    Status	 up
    PPPoE	 up    
    Uptime	 00:00:0
    MAC address	 00:00:00:00:00:00
    IPv6 Link Local	 fe80::4e02:89ff:fe00:4582%em1	  
    In/out packets	 0/7 (0 bytes/520 bytes)
    In/out packets (pass)	 0/7 (0 bytes/520 bytes)
    In/out packets (block)	 0/0 (0 bytes/0 bytes)
    In/out errors	 0/0
    Collisions	 0
    
    Last 50 PPP log entries
    Mar 9 23:26:06	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:26:06	ppp: [opt1_link0] MRU 1492
    Mar 9 23:26:06	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:26:06	ppp: [opt1_link0] LCP: SendConfigReq #140
    Mar 9 23:26:04	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:26:04	ppp: [opt1_link0] MRU 1492
    Mar 9 23:26:04	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:26:04	ppp: [opt1_link0] LCP: SendConfigReq #139
    Mar 9 23:26:02	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:26:02	ppp: [opt1_link0] MRU 1492
    Mar 9 23:26:02	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:26:02	ppp: [opt1_link0] LCP: SendConfigReq #138
    Mar 9 23:26:00	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:26:00	ppp: [opt1_link0] MRU 1492
    Mar 9 23:26:00	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:26:00	ppp: [opt1_link0] LCP: SendConfigReq #137
    Mar 9 23:25:58	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:25:58	ppp: [opt1_link0] MRU 1492
    Mar 9 23:25:58	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:25:58	ppp: [opt1_link0] LCP: SendConfigReq #136
    Mar 9 23:25:56	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:25:56	ppp: [opt1_link0] MRU 1492
    Mar 9 23:25:56	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:25:56	ppp: [opt1_link0] LCP: SendConfigReq #135
    Mar 9 23:25:54	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:25:54	ppp: [opt1_link0] MRU 1492
    Mar 9 23:25:54	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:25:54	ppp: [opt1_link0] LCP: SendConfigReq #134
    Mar 9 23:25:52	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:25:52	ppp: [opt1_link0] MRU 1492
    Mar 9 23:25:52	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:25:52	ppp: [opt1_link0] LCP: SendConfigReq #133
    Mar 9 23:25:50	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:25:50	ppp: [opt1_link0] MRU 1492
    Mar 9 23:25:50	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:25:50	ppp: [opt1_link0] LCP: SendConfigReq #132
    Mar 9 23:25:48	ppp: [opt1_link0] MAGICNUM 0bf5e568
    Mar 9 23:25:48	ppp: [opt1_link0] MRU 1492
    Mar 9 23:25:48	ppp: [opt1_link0] PROTOCOMP
    Mar 9 23:25:48	ppp: [opt1_link0] LCP: SendConfigReq #131
    Mar 9 23:25:48	ppp: [opt1_link0] LCP: state change Starting --> Req-Sent
    Mar 9 23:25:48	ppp: [opt1_link0] LCP: Up event
    Mar 9 23:25:48	ppp: [opt1_link0] Link: UP event
    Mar 9 23:25:48	ppp: [opt1_link0] PPPoE: connection successful
    Mar 9 23:25:48	ppp: PPPoE: rec'd ACNAME "Vigor2000 PPPoE"
    Mar 9 23:25:48	ppp: [opt1_link0] PPPoE: Connecting to ''
    Mar 9 23:25:48	ppp: [opt1_link0] Link: reconnection attempt 13
    Mar 9 23:25:45	ppp: [opt1_link0] Link: reconnection attempt 13 in 3 seconds
    Mar 9 23:25:45	ppp: [opt1_link0] LCP: LayerStart
    Mar 9 23:25:45	ppp: [opt1_link0] LCP: state change Stopped --> Starting
    

    What am I doing wrong? The Draytek has no problem with acquiring an IP when PPoE passtrough is disabled.



  • I've set up a draytek 130 vdsl same setup .. I found that this exact issue is due to the setup of the draytek.

    ensure you have setup the router correctly… and update the fermware to the latest verison

    a quick setup (ensure you save the config as asked and conferm settings at end as my draytek lost vlan tag each time)

    *** ADSL Connection

    1. Reset router factory defaults
    2. Compete Quick Internet Wizard
    3. Disable PPPoE/PPPoA client                    (internet access >> PPPoE/PPPoA)
    4. Enable PPPoe Passthrough                      (internet access >> PPPoE/PPPoA)

    *** VDSL connection

    1. Reset router factory defaults
    2. Enable vlan and enter tag                      (internet access >> general setup)
    3. Disable PPPoE/PPPoA client                    (internet access >> PPPoE/PPPoA)
    4. On MPoA set                                            (internet access >> MPoA / static or dynamic IP)
                            a)  MPoa (rfc1483/2684) >>>  enabled
                            b)  Encapulation >>> 1483 Bridged IP (IPoE)
                            c)  MTU >>> 1492

    If vlan is enabled in step 2 then no vlan settings are needed on the pfsense firewall

    hope this helps :)

    Bodie


Log in to reply