Odd Duplicate warnings in DHCP Log



  • This is what's coming up in the DHCP logs.  Just these two machines out of about 30.  Every hour this is happening.

    Almost all of the machines on the network, including these 2, are set to pull the same IP every time by MAC.  If you go to either machine, an ipconfig shows just the one adapter in them, and shows it with the right IP.  DHCP renew time is 2 hours (default).

    Anyone have any ideas what might be causing this?

    Dec 6 09:08:54 dhcpd: uid lease 10.0.0.198 for client 00:13:d4:f4:6c:31 is duplicate on 10.0.0/24
    Dec 6 09:24:33 dhcpd: uid lease 10.0.0.193 for client 00:c0:a8:84:54:bf is duplicate on 10.0.0/24
    Dec 6 10:08:54 dhcpd: uid lease 10.0.0.198 for client 00:13:d4:f4:6c:31 is duplicate on 10.0.0/24
    Dec 6 10:24:33 dhcpd: uid lease 10.0.0.193 for client 00:c0:a8:84:54:bf is duplicate on 10.0.0/24
    Dec 6 11:08:54 dhcpd: uid lease 10.0.0.198 for client 00:13:d4:f4:6c:31 is duplicate on 10.0.0/24
    Dec 6 11:24:33 dhcpd: uid lease 10.0.0.193 for client 00:c0:a8:84:54:bf is duplicate on 10.0.0/24
    Dec 6 11:38:07 dhcpd: uid lease 10.0.0.193 for client 00:c0:a8:84:54:bf is duplicate on 10.0.0/24
    Dec 6 11:38:07 dhcpd: uid lease 10.0.0.193 for client 00:c0:a8:84:54:bf is duplicate on 10.0.0/24
    Dec 6 11:41:32 dhcpd: uid lease 10.0.0.193 for client 00:c0:a8:84:54:bf is duplicate on 10.0.0/24
    Dec 6 12:08:54 dhcpd: uid lease 10.0.0.198 for client 00:13:d4:f4:6c:31 is duplicate on 10.0.0/24
    Dec 6 12:41:32 dhcpd: uid lease 10.0.0.193 for client 00:c0:a8:84:54:bf is duplicate on 10.0.0/24
    Dec 6 13:08:54 dhcpd: uid lease 10.0.0.198 for client 00:13:d4:f4:6c:31 is duplicate on 10.0.0/24
    Dec 6 13:41:32 dhcpd: uid lease 10.0.0.193 for client 00:c0:a8:84:54:bf is duplicate on 10.0.0/24
    Dec 6 14:08:54 dhcpd: uid lease 10.0.0.198 for client 00:13:d4:f4:6c:31 is duplicate on 10.0.0/24



  • Are these machines made from the same Image using disk imaging tools?



  • Have those machines been assigned a DHCP lease dynamically from the pool before the MAC got a static mapping (with a different IP?



  • @jahonix:

    Have those machines been assigned a DHCP lease dynamically from the pool before the MAC got a static mapping (with a different IP?

    I have the exact same messages in my log, and I think that I also assigned a dynamic address to the device before it got a static one.
    I've tried to remove it from the lease file, restarting the DHCP server, but nothing seems to work.

    How do you solve this?

    [edit]
    I should've looked a bit more carefully on the forum, the solution is in this thread:
    [/edit]


Log in to reply