A pagina nao bloqueia ate limpar o cache do navegador



  • Ola a todos, sou novo no pfsense e estou tendo muitas dificuldades, uma delas é nas regras de bloqueios que mesmo ao passar o tempo, se continuar acessando ele nao bloqueia. O bloqueio so vem ocorrer se eu fechar a pagina e tentar abrir depois ou ficar sem mexer por um periodo. O mesmo problema acontece no dia seguinte quando chega no horario permitido ele nao acessa pois aparece como bloqueado, mais se limpar o cache na maquina cliente funciona as regras.

    Como nao conheço muito pode me ajudar mostrado os procedimentos que vou ter que fazer?



  • Johnnatha,

    Explique melhor seu ambiente para conseguirmos te ajudar.

    Qual versão do pfsnese você usa? que pacotes tem instalado?



  • Meu Pfsense a versão é 2.1

    Tenho os pacotes Squid e squidGuard instalados. Fiz alguns grupos e determinei que no horario de 12:00 as 13:00 o acesso ao facebook seria liberado, isso tudo setando o proxy manualmente para poder bloquear tanto http e hhtps sem fazer regras pelo firewall, quando esta no horario ele funciona blz e so vem bloquear depois do horario se eu nao ficar mexendo, caso depois do horario eu continue atualizando ele nao bloqueia, se eu paro de mexer por alguns min ele bloqueia. Agora no dia seguinte se eu nao limpar o cache do navegado para acessar o facebook ele fica apresentando o bloqueio de tela, nesse caso tenho que limpar o cache e entrar no face.

    Estou com o problema de liberar download para certas pessoas tambem, atualmente esta liberado a taxa para todos.



  • Boa noite Johnnathabessa,

    Utilize esse tutorial: https://www.youtube.com/watch?v=neXcYtFDRLA

    La explica como configurar o squid3 nele funciona redondinho!!



  • @johnnathabessa:

    Ola a todos, sou novo no pfsense e estou tendo muitas dificuldades, uma delas é nas regras de bloqueios que mesmo ao passar o tempo, se continuar acessando ele nao bloqueia. O bloqueio so vem ocorrer se eu fechar a pagina e tentar abrir depois ou ficar sem mexer por um periodo. O mesmo problema acontece no dia seguinte quando chega no horario permitido ele nao acessa pois aparece como bloqueado, mais se limpar o cache na maquina cliente funciona as regras.

    Como nao conheço muito pode me ajudar mostrado os procedimentos que vou ter que fazer?

    Tambem tenho o mesmo problema com os horários, se eu continuar usando um site bloqueado por horário mesmo apos o horário de bloqueio, o mesmo continua funcionando, a regra é aplicada novamente somente se fechar e abrir novamente o navegador.

    Utilizo o pfsense 2.1 e squid3 e Aliases

    O pessoal já até pegou a manha, deixei o face liberado de 12:00 as 14:00, alguns espertos deixam o navegador aberto após as 14:00 e o face continua o acesso normal.  :-\



  • Boa noite, se você tiver domínio, configure no AD para que sempre que fechar o navegar automaticamente sejam apagados o cache. Existe template para IE, Chrome e firefox.



  • Obrigado a todos por esta ajudando. Joaobrn esse video mostra utilizando proxy transparente e na realidade eu seto o proxy nas maquinas clientes, pelo fato de bloquear o http e https no caso do facebook.



  • Boa noite johnnathabessa,

    Eu entendo que é proxy transparente mas com o squid3 é possivel se bloquear facebook com proxy transparente nos protocolos http e https. Faça o teste você mesmo seguindo o vídeo ou assista o video por completo caso não tenho feito.



  • Joao, fiz de acordo com o video mais na versao mais recente do pfsense e tive problema com o certificado, pois quando entro no google.com da erro, e em outros sites tambem.



  • @johnnathabessa:

    Joao, fiz de acordo com o video mais na versao mais recente do pfsense e tive problema com o certificado, pois quando entro no google.com da erro, e em outros sites tambem.

    Bom dia Johnnatha, você olhou as observações que coloquei no vídeo?? vou postar aqui para que você tome conhecimento. Quanto ao google.com se você usar pelo google Chrome, realmente não funciona mas não por um problema do PFSense. Eu entrei em contato com o google e eles me disseram que isso é um nível de segurança que o Google Chrome tem para evitar que o site deles sejam interceptado por um hacker ou coisa assim.

    Segue as infomações:

    PESSOAL UMA OBSERVAÇÃO MUITO IMPORTANTE. LEMBREM-SE DE OLHAR SE A DATA DO PFSENSE ESTÁ CORRETA DE ACORDO COM O MERIDIANO DE GRENWICH POIS, CASO ELA ESTEJA ERRADA O CERTIFICADO DARÁ ERRO.
    FIQUEM ATENTOS.

    OUTRA COISA QUE AGORA É NECESSÁRIO FAZER PARA RODAR COM AS NOVAS BIBLIOTECAS,
    ADICIONEM AS  LINHAS DENTRO DE "Custom ACLS (Before_Auth)"

    always_direct allow all
    ssl_bump server-first all

    depois manda salvar, reiniciar o serviço e testem!!



  • agende no cron um squid -k reconfigure para o horario necessario…



  • johnnathan, estava com o mesmo problema durante muitos teste achei a solução,

    Em Proxy Server>Cache Management>Squid Cache General Settings  … mude de Heap LFUDA para Heap LRU, e em
    Dynamic and Update Content>Select to enable caching of dynamic content marque a caixa

    dessa forma não é necessario limpar o cache no navegador, aqui funcionou. 8) 8) 8)



  • Luizfc fiz esse procedimento aqui funcionou. o usuário so tem que fechar e abrir o navegador para ter o acesso.

    Obrigado



  • Obrigado pelo feedback



  • @Luizfc:

    johnnathan, estava com o mesmo problema durante muitos teste achei a solução,

    Em Proxy Server>Cache Management>Squid Cache General Settings  … mude de Heap LFUDA para Heap LRU, e em
    Dynamic and Update Content>Select to enable caching of dynamic content marque a caixa

    dessa forma não é necessario limpar o cache no navegador, aqui funcionou. 8) 8) 8)

    luizfc Legal essa não conhecia só pra entender vc sabe o que significa essas siglas ou explicar o pq funcionou



  • Alguem teve sucesso? estou com o mesmo problema



  • Alguem teve sucesso? estou com o mesmo problema


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy