Packages moved to their own server and HTTPS



  • Package files are now pointing to https://packages.pfsense.org, to put them on their own server, and switch from HTTP to HTTPS. Existing systems on 2.x versions will pull the package list via http://www.pfsense.com still, but fetch additional files via HTTPS, including now the PBI downloads.

    Starting with the next 2.1.1 snapshot after my commits a bit ago, 2.1.1 and newer will also fetch the package list via https://packages.pfsense.org (but that's hard-coded on existing installs and won't change without an upgrade).

    Packages will remain available via http://www.pfsense.com for at least 1 year from now. At some point after that, we'll remove packages completely from www, but will give people plenty of time to get upgraded to newer releases before doing so.



  • I have been trying to install some packages on a couple of older PFSense boxes we have that are still on 1.2.3 and cannot be upgraded. I installed some packages a couple of weeks ago just fine. Today I tried installing several different packages and they all stop at "Loading package configuration…". I have tried on both embedded systems on the ALIX platform, as well as with a system with a hard drive in it. I checked the forum and it looks like there was a change to the packaging servers on March 13. Any idea what might be happening?
    Thanks



  • v1.2.3 packages are no longer supported, that's almost a 5 year old release now, and 6 releases behind current within a few days when 2.1.1 is released. There isn't any reason you can't upgrade them. That said, ones that worked a couple weeks ago should still work now. We're not intentionally breaking them (yet), but some are broken because they now require PHP 5.

    My first guess is maybe something about those systems is preventing them from fetching files via HTTPS. Go to a command prompt and run:

    fetch https://packages.pfsense.org/packages/config/filer/filer.xml

    see if that succeeds. If not, try:
    fetch http://packages.pfsense.org/packages/config/filer/filer.xml


Log in to reply