ATIVAR DNS PFSENSE EMAIL NAO SAI DA CAIXA DE SAIDA



  • Bom noite, senhores. Começei a utilizar o pfsense recentemente e está ocorrendo os seguintes problemas:

    Problema 1
    A interface WAN pega um ip automático distribuído pelo roteador no meu serviço, dessa forma consigo navegar na web normalmente.
    Mas eu quero configurar ip estático em minha interface WAN, porém, sempre que configuro o ip que desejo utilizar o pfsense não acessa mais a internet, mesmo que coloque o mesmo ip que foi atribuído via DHCP.

    Problema 2
    tenho os pacotes do squid+light squid intalados e configurados se configuro no dhcp os endereços de gateway e dns 192.168.253.3 (pfsense) eu consigo bloquear os sites proibidos porem nao consigo enviar emails com anexo, se configuro o dhcp com os endereços de gateway e dns 192.168.254.254 eu envio os emails normalmente porem a internet fica liberada.

    abaixo segue meu cenário:

    Modem ADSL
    ip para acesso: 192.168.254.254

    PFsense:
    IP WAN: DHCP
    Gateway para web: 192.168.254.254 (Meu roteador/modem)
    DNS: 8.8.8.8 / 8.8.4.4 (DNS da google definido também manualmente)

    IP LAN: 192.168.253.3/24

    Estações de trabalho:
    Recebe DHCP do PFSense no range 192.168.254.20 - 192.168.254.80 com máscara de sub-rede 255.255.255.0
    Gateway: 192.168.254.254
    DNS: 192.168.254.3

    Desde já agradeço a atenção e ajuda de vocês.



  • Boa noite Clauber Rocha,

    Referente ao problema 1 é necessário criar um gateway para que seu pfsense consiga se comunicar com o modem, porém para melhorar a segurança da sua rede te recomento a configurar o seu modem como PPPOE a não ser que esteja utilizando um roteador com link dedicado. Para criar o gateway basta ir em Interface > WAN > Static IPv4 configuration > gateway e clique em "add a new one" e então você informa o ip do seu modem 192.168.254.254. Clique em Save e depois em Apply Settings lembre-se de desmarcar "Block private networks" e "Block bogon networks" senão você não conseguirá navegar.

    Referente ao segundo problema, realmente se vc utilizar o gateway 192.168.254.254 seu trafego não será filtrado pois está caindo direto no modem.

    O correto é vc utilizar o ip 192.168.253.3 como gateway e verifique nas suas regras se possui alguma expressão regular que possa estar bloqueando esses anexos. Verifique também as configurações de tamanho de arquivos que podem ser baixado e enviados se estão configurados com tamanhos coerentes com os anexos que você está enviando.


  • Administrator

    Considere configurar o modem para trabalhar em modo bridge, e dessa maneira jogar o IP roteável na WAN do pfSense, senão você fará um duplo NAT, o que torna a sua rede mais complicada.

    Se isso não for possível, já verificou se a opção de bloqueio a redes da RFC 19198 está marcada na página de configuração da WAN? 192.168.x.x é uma classe da RFC 1918.



  • @joaobrn:

    Boa noite Clauber Rocha,

    Referente ao problema 1 é necessário criar um gateway para que seu pfsense consiga se comunicar com o modem, porém para melhorar a segurança da sua rede te recomento a configurar o seu modem como PPPOE a não ser que esteja utilizando um roteador com link dedicado. Para criar o gateway basta ir em Interface > WAN > Static IPv4 configuration > gateway e clique em "add a new one" e então você informa o ip do seu modem 192.168.254.254. Clique em Save e depois em Apply Settings lembre-se de desmarcar "Block private networks" e "Block bogon networks" senão você não conseguirá navegar.

    Referente ao segundo problema, realmente se vc utilizar o gateway 192.168.254.254 seu trafego não será filtrado pois está caindo direto no modem.

    O correto é vc utilizar o ip 192.168.253.3 como gateway e verifique nas suas regras se possui alguma expressão regular que possa estar bloqueando esses anexos. Verifique também as configurações de tamanho de arquivos que podem ser baixado e enviados se estão configurados com tamanhos coerentes com os anexos que você está enviando.

    gostaria desde ja agradecer a vcs que me deram informacoes importantes, vou configurar e testar assim que terminar posto aqui no forum qual o resultado.



  • @Renato:

    Considere configurar o modem para trabalhar em modo bridge, e dessa maneira jogar o IP roteável na WAN do pfSense, senão você fará um duplo NAT, o que torna a sua rede mais complicada.

    Se isso não for possível, já verificou se a opção de bloqueio a redes da RFC 19198 está marcada na página de configuração da WAN? 192.168.x.x é uma classe da RFC 1918.

    Caro amigo quanto a opcao de bloqueio todas as duas opcoes estão desmarcadas. vou testar aqui e logo postarei o resultado.



  • Galera boa tarde somente hj tive como testar as dicas que os amigos me deram, coloquei o modem como PPOE, fui na INTERFACE WAN - STATIC IPV4 CONFIGURATION - GATEWAY e la adicionei um novo gateway e configurei-o como gateway o ip 192.168.254.3 (ip do pfsense), as regras do squid funcionam blz, porém ao enviar email com anexo eles não saem, muito embora estão liberadas no firewall as regras para as portas POP3(110), POP3S(995), 587, IMAP(143), IMAPS(993), SMTP(25), SMTPS(465), daí se os emails não tiverem anexo passam sem problema.



  • @clauberocha:

    Galera boa tarde somente hj tive como testar as dicas que os amigos me deram, coloquei o modem como PPOE, fui na INTERFACE WAN - STATIC IPV4 CONFIGURATION - GATEWAY e la adicionei um novo gateway e configurei-o como gateway o ip 192.168.254.3 (ip do pfsense), as regras do squid funcionam blz, porém ao enviar email com anexo eles não saem, muito embora estão liberadas no firewall as regras para as portas POP3(110), POP3S(995), 587, IMAP(143), IMAPS(993), SMTP(25), SMTPS(465), daí se os emails não tiverem anexo passam sem problema.



  • Problema 1:
    Considere efetuar uma reserva de IP através de seu router para o IP do PFsense ao invés de fixar manualmente no PF

    Problema 2:
    No meu ambiente foi necessário liberar no firewall os IPs do server que hospeda meus e-mails e colocar o dominio do mesmo em whitelist (sem autenticacao)



  • @lucaspolli:

    Problema 1:
    Considere efetuar uma reserva de IP através de seu router para o IP do PFsense ao invés de fixar manualmente no PF

    Problema 2:
    No meu ambiente foi necessário liberar no firewall os IPs do server que hospeda meus e-mails e colocar o dominio do mesmo em whitelist (sem autenticacao)

    Na minha whitelist ta liberado tudo só bloqueado na blacklist facebook, orkut, sites com terminacao blogspot. Há so lembrando mesmo os ips constantes na minha UnrestrictedIPs nao conseguem enviar emails.



  • Eu continuo com o mesmo problema ao lançar o gateway padrao o ip do pfsense, ninguem conecta na internet, nas minhas regras de firewall da minha LAN eu liberei os protocolos http(80), https(443) e dns((53). Eu agradeço a ajuda.



  • @clauberocha:

    Bom noite, senhores. Começei a utilizar o pfsense recentemente e está ocorrendo os seguintes problemas:

    Problema 1
    A interface WAN pega um ip automático distribuído pelo roteador no meu serviço, dessa forma consigo navegar na web normalmente.
    Mas eu quero configurar ip estático em minha interface WAN, porém, sempre que configuro o ip que desejo utilizar o pfsense não acessa mais a internet, mesmo que coloque o mesmo ip que foi atribuído via DHCP.

    Problema 2
    tenho os pacotes do squid+light squid intalados e configurados se configuro no dhcp os endereços de gateway e dns 192.168.253.3 (pfsense) eu consigo bloquear os sites proibidos porem nao consigo enviar emails com anexo, se configuro o dhcp com os endereços de gateway e dns 192.168.254.254 eu envio os emails normalmente porem a internet fica liberada.

    abaixo segue meu cenário:

    Modem ADSL
    ip para acesso: 192.168.254.254

    PFsense:
    IP WAN: DHCP
    Gateway para web: 192.168.254.254 (Meu roteador/modem)
    DNS: 8.8.8.8 / 8.8.4.4 (DNS da google definido também manualmente)

    IP LAN: 192.168.253.3/24

    Estações de trabalho:
    Recebe DHCP do PFSense no range 192.168.254.20 - 192.168.254.80 com máscara de sub-rede 255.255.255.0
    Gateway: 192.168.254.254
    DNS: 192.168.254.3

    Desde já agradeço a atenção e ajuda de vocês.