Urgent Issue : BANDWIDTHD failed to boot up pfSense



  • Hi All,

    I'm preparing two pfsense units to be installed in a couple of days.

    After the installation of extra packages, I rebooted one unit but pfsense in not booting up. I have a serial connection attached to the appliance and I get this message :

    Starting syslog...done.
    Starting CRON... done.
     Starting package bandwidthd...Enter full pathname of shell or RETURN for /bin/sh:
    

    If I type in "exit", pfSense reboot and still the same error…

    How can I fix this please ! :-)

    I was wopndering removing the package from startup config file, and then remove the pacakge.

    I really need help :-)

    Thanks a lot


  • Rebel Alliance Developer Netgate

    I've seen a small number of similar reports, always with bandwidthd, but I can never replicate it locally.

    Something in the bandwidthd startup is causing it, but it's never been clear what and no matter what settings I've tried, it always works for me.

    If you can show the bandwidthd config part of your config.xml and the bandwidthd config from the filesystem, and the rc script from /usr/local/etc/rc.d/ that may be a good start.


  • Banned

    bandwidthd never ever started after reboot. Not on a single box. (Meanwhile, I've abandoned the package.)



  • I ran into the same problem recently. Haven't figured out how to fix this.

    I disabled every option from the config dialog :

    
                    <bandwidthd><config><enable>on</enable>
                                    <active_interface>lan</active_interface>
                                    <subnets_custom><skipintervals><graphcutoff><promiscuous><outputcdf><recovercdf><outputpostgresql><postgresqlhost><postgresqldatabase><postgresqlusername><postgresqlpassword><sensorid><filter><drawgraphs><meta_refresh><graph_log_info></graph_log_info></meta_refresh></drawgraphs></filter></sensorid></postgresqlpassword></postgresqlusername></postgresqldatabase></postgresqlhost></outputpostgresql></recovercdf></outputcdf></promiscuous></graphcutoff></skipintervals></subnets_custom></config></bandwidthd> 
    
    

    Must be noted that

    • if I launch /usr/local/bandwidthd/bandwidthd using ssh, bandwidthd is starting without error message.
    • if I add /usr/local/bandwidthd/bandwidthd to shellcmd, the same error message appears


  • and I have seen this in the past also, but I can't replicate it. I have also had something about missing libs. After reinstalling bandwidthd it all went away and I could not make it come back.
    If someone can replicate it, then I am happy to look into how to fix it.



  • I've come to the same problem during upgrade, only previously bandwidthd was installed, but not configured fully. After upgrade from 2.1-2.1.3, web configurator didin't boot, and had this error in console.

    I can not say, what was the case, and have to investigate it later, but I:

    • Hit Return as suggested, moving to console commandline
    • entered: fsck -y (did path checks of file system)
    • entered: reboot (or full system reboot)

    And this error disappeared and router booted normally.



  • I have the same problem.

    When pfSense boots, it shows Starting package bandwidthd… and ask for the full pathname of shell or RETURN for /bin/sh:

    And when I tried to login in the GUI/web, it shows
    500 - Internal Server Error
    and when I press refresh:
    503 - Service Not Available

    After 2 reboots, it passes for the Starting package bandwidthd... done
    And now stops in the
    Starting package squid... Enter full pathname.......

    It's a brand new instalation.



  • Same here, new install, bandwidthd error.

    Installed the 2.2 upgrade on another machine and it got hosed, won't reboot….

    ugh.


Log in to reply