New Install - Can't Ping Public IP



  • I did a brand new install of PFSense.  I followed the basic setup.  My two NICs have a static internal LAN IP and DHCP WAN.  I can see the WAN has an IP from Comcast.  I can ping local LAN IPs and the WAN IP.  I cannot ping external IPs.  I've tried pinging 8.8.8.8 & 75.75.75.75.  Can someone point me to what could be wrong?

    Thanks,
    seag33k



  • I am not sure what was wrong, but I was using a different 192.168.x.0 subnet that the default 192.168.1.1.  When I sued the default things started working.



  • Same problem here - exactly as you described it.

    If I perform a vanilla install then everything works.  If I make a minor change to set the internal network to a 192.168.0.X instead of the default 192.168.1.X then routing dies.

    I can perform NSlookups from the diagnostics and the WAN interface will get an IP from DHCP but other than that nothing works.



  • Is the WAN actually getting a private IP by DHCP from your ISP front-end router device?
    If it gets the subnet 192.168.0.0/24 that will conflict with LAN and stuff things up.
    Do not set the LAN subnet to the same (or overlapping) what is on WAN.



  • What Phil said is what people that actually understand things say  ;D

    Me can add a noob contribution: I just installed a new NIC and added a WAN-interface. I got an external ip, but couldn't ping google. Reboot, and done, it worked.



  • Yes, reboot is a great help for Pfsense, indeed.


Log in to reply